Main Site Documentation

STDFU Tester gets 0xc0150002 error during launch


#1

In attempting to follow the loader update instructions for the FEX Cerberus. I launched the STDFU Tester, and immediately got a 0xc0150002 from Windows (application failed to initialize properly). I’m running a fresh install of Windows 7 Pro 32-bit with all the updates, and am using the latest downloads from GHI.

Update: I get the same error (a) after performing a repair installation, (b) after completely uninstalling and reinstalling the SDK, and © whether or not the Cerberus is attached to the system.

Is this a known behavior, and is there a workaround)?

Thanks.


#2

certainly not a known issue, and unfortunately one that STM are likely to need to understand since it is their tool not GHIs. That error is a generic Windows app failed to start message, but a quick bing found this thread http://forums.netduino.com/index.php?/topic/8209-netduino-plus-2-erase-app/#entry46061 so try removing the driver they talk about…


#3

@ Brett -

Thanks very much for your reply.

Unfortunately, I couldn’t find the mentioned STM32 BOOTLOADER device (or any other device having to do with STM) in Device Manager, whether I had the device attached with or without the Boot pads jumpered. I checked under every device category, just to be sure. Nothing even remotely STM-ish. The only thing I saw after installing the SDK is GHI NETMF Interface under USB devices.

So, ignoring that step, I went ahead and uninstalled the STMicroelectronics DfuSe v 3.0.2, and downloaded from http://www.st.com/st-web-ui/static/active/en/st_prod_software_internet/resource/technical/software/demo_and_example/stsw-stm32080.zip to install STMicroelectronics DfuSe v 3.0.3. I ran the new STDFU Tester, and it came up fine. Progress!

I then followed the remaining steps to update the loader and then the firmware, and all worked without a problem.

So, it looks like version 3.0.2 of the STM stuff didn’t like my system for some reason, but version 3.0.3 was happy with my system.

Thanks again.