Main Site Documentation

Startup Logo, Odd Behavior


#1

I added a startuplogo for the first time on the Raptor and it went perfectly, but then I decided to change to logo and I got, really, the strangest result I’ve ever seen.

1: Started with black and white image, perfect result
2: Moved image down a bit and added some stuff, soft reboot: no change, hard reboot, no change
3: Disabled startup logo, soft reboot, hard reboot, works fine.
4: Enabled startup logo, designated new logo, soft reboot: no change, hard reboot, no change
5: Changed formats, soft reboot: no change, hard reboot, no change
6: Changed filenames, soft reboot: no change, hard reboot, no change
7: StartupLogo.Image.DrawRectangle (filled with red) all the white bits were now red and the black bits were still black?!!
8: Completely changed the logo to be a gradient from green to yellow to red, the top part of the logo changed, the rest remains the same

I’m baffled. I did an application erase, no affect. I did a complete reinstall of the firmware, no affect.


#2

@ Skewworks - Could you post some code that we can use to try and reproduce this?


#3

There’s really no code to it. But sure, here you go.

GHI.Processor.StartupLogo.Image = Images.ImageFromBytes(Resources.GetBytes(Resources.BinaryResources.test));
            GHI.Processor.StartupLogo.X = 480 / 2 - 90;
            GHI.Processor.StartupLogo.Y = 272 / 2 - 90;
            GHI.Processor.StartupLogo.Enabled = true;
            Debug.Print("Saving startup logo: " + GHI.Processor.StartupLogo.Save());

Obviously I’ve tried it with

 so it didn't keep saving over and over. I've tried it without. All of the very few variations that are available to try for turning this on and off...I have tried.

#4

@ Skewworks - We will take a look for the next SDK. If you need to get back to a working state, you can erase the board and reload TinyBooter and the firmware.


#5

No, I can’t. I mentioned in the first post that has zero effect.


#6

@ Skewworks - Even the batch file that is used to reload TinyBooter? That should erase the entire flash. Can you read the log to verify it did everything successfully?


#7

No I’ve only reloaded the firmware not the TinyBooter.


#8

@ Skewworks - you will need a complete erase to wipe out the logo region


#9

I will do that if I have to but I’m really hoping you guys will take a look into what’s actually wrong. I’d hate to have to completely reload the board, TinyBooter and all, anytime I want to do something as simple as change the startup logo.


#10

@ Skewworks - we will be taking a look for the next SDK.


#11

OK so then I should treat this as a known issue for now?

It’s not a problem if that’s the answer, as long as I have one. :slight_smile:


#12

As long as we can reproduce, we can fix. I am afraid this us one of those extremely rare ones. We will also review the code and improved anything we see can be improved.


#13

@ Skewworks - We have not tried to reproduce it yet. It is on our list though to take a look at. If we can reproduce it then it is a known issue.