Starting up and Firmware Issues


I just installed all the necessary software as per the steps given on the .NET Micro Framework page.
I using Windows 7 on my laptop and downloaded and installed GHI Electronics NETMF SDK 2015 R1 Pre-Release 3 as the SDK.

I am trying to start a project using the FEZ Panda II to control a small robot chassis over the internet.
I got the following errors when trying to deploy the sample code onto the device and the results of checking the device for updates using FEZ Config, which are clearly different from what should be shown according to the ‘.NET Micro Framework for Beginners’ document.
Check the screenshot for the errors…

When I try use the firmware updater in FEZ Config it says under Firmware on this computer - Not found for this device.
In my local drive under the path to NETMF v4.3 SDK and in firmwares the is no firmware for USBizi, should this be there?

Any help would be much appreciated!!!


@ Slanstey - The FEZ Panda II only supports NETMF 4.1. You need an older SDK:

@ Slanstey

You can install the NetMF 4.1 side by side with the GHI Electronics NETMF SDK 2015 R1 Pre-Release 3.

Don´t forget to set the solution target framework to 4.1.

If you use References. Check it. If there NETMF 4.3 References inside you get problems.

@ Wolfgang and @ John - thanks for the tips

I have tried both with and without the newest SDK installed.
At the moment I have uninstalled the newest SDK and only have v4.1 installed yet I am still getting problems.
I had to manually install the driver found in the GHI Electronics folder on my local disk under USB Drivers n the SDK folder.
Then Fez Config obviously only comes with the newer SDKs but when I try use the USBiziUpdater program it says I am doing the steps wrong and then of course Visual Studio throws the same error as before…

Not sure where I am going wrong???

Thanks for the help again, much appreciated!


@ Slanstey -

There is nothing to do with FEZConfig
You need to switch from 4.3 to 4.1, see attached image below

@ Dat - yes! thanks a lot seems to be working fine now

Just trying to flash an LED except its giving me an error saying the name GHI does not exist in the current context.
I have added almost all the references to the project, perhaps I have to have another using statement.
See screenshot attached…

I am still getting used to Visual Studio and C# so thanks for the help!


So right now you’re getting new code confused with old code.

GHI.Pins is a 4.3 method of accessing pins. And you don’t have a G80 so you would never be able to correctly reference a pin that way.

For a start however, you need to clean up your references. FezPanda and Panda2 - choose one ! Gadgeteer is not applicable so get rid of it. SQLLite is not implemented on USBizi (iirc), so get rid of it. Adding all the references is a bad idea :slight_smile: .

To reference D1, you would use:

@ Slanstey - Have you tried the netmf beginner’s guide? It is the last step in the setup process on the NETMF support page. Just follow the steps please.

The guide is good Gus, but likely still going to lead a newbie down the wrong path as they’re unlikely to have learnt enough to understand what they would need to revert back to 4.1 and a USBizi device…

As far as the very beginning, the emulator, blinking an led and reading a button, I think all apply exactly the same.

Sure do !! (but unravelling hardware references to include, mapping pins to real hardware etc, that’s where it gets a little sketchy in my view… maybe we need a “getting started with ” page for each board that helps people understand some of these things?)

Let me think about this some more.

@ Gus - I have been following the beginners guide however it gives the example for flashing the LEDs that leads to the problem I am currently having. It is more of a beginners guide for NETMF in general than for the Fez Panda II and USBizi devices.

Just tough getting to know how to reference the pins and in future the ADT and etc components for the specific board I am using, as @ Brett says.

Is there perhaps some code examples for the FEZ Panda II specifically?
I have changed the reference to use pin D1 except now ii is giving me an error with the argument and says that reference does not match Microsoft.SPOT.Hardware.Cpu.Pin and therefore throws an error saying the best overloaded method match has some invalid arguments. I have left the ‘true’ boolean value in the arguments as OutputPort says it needs it so I am pretty certain it is the pin reference giving issues.
Also the only project references I have included now are Microsoft.SPOT.Hardware and FEZPanda_II_GHIElectronics.NETMEF.FEZ

Thanks for help so far though, much appreciated!


ok I seem to have sorted it all out by adding the Microsoft.SPOT.Native reference and casting the pin using (Cpu.Pin).

So got the board up and running just having a problem now when trying to implement the motors.
I am trying to make a PWM however in the beginners guide it says I need to add the reference Microsoft.SPOT.Hardware.PWM assembly however this is not on the list I have.

I have found it in the v4.2 and v4.3 when browsing for the assembly under Microsofts .NET MicroFramework however I am unsure if this will be allowed as the SDK is v4.1???
When I add it it takes the error of the misisng namespace for PWM except I can’t cast the pin to the needed Cpu.PWMChannel.

Heres the line of code I am trying to get to work:
PWM MyFader = new PWM((Cpu.PWMChannel)FEZ_Pin.PWM.Di10,10000,0.1,false);

Any ideas?


It won’t let you deploy with the Microsoft.SPOT.Hardware.PWM from v4.3 anyway so how do I get the correct assembly version for the FEZ Panda?

Pwm back then was not part of netmf. You will find pwm support in the ghi libraries. The 4.1 library documentation is in your sdk and also here .NET Micro Framework – GHI Electronics

Remember this application flow. Create new project (netmf console application). Immediately switch project target framework version to 4.1. When adding references, NEVER use the “Browse” option to add references that you think you might want; if it’s not offered in the “.Net” tab, then it doesn’t apply to your device.

If you do anything outside that workflow you’ll get yourself in trouble.

If you are trying to use current documentation for an old device like this, I’d suggest you might want to think about buying a new device that supports the current stack, that the current examples are likely to work with.

As Gus says, the old doco is still around but you’re not likely to find actual examples on how to achieve everything you may want. .NET Micro Framework – GHI Electronics has links to all the GHI library documentation for older versions that you can use. You can also use codeshare to find examples that use features you’re interested in.

If this is the case now then perhaps I must reconsider the micro I am using. Initially the FEZ panda was given to me and I thought it would be really easy for the task at hand.
Without the capabilities for a simple PWM then will it have the capabilities for the rest of my project? This includes video footage that must be sent via wifi to a computer. I have looked at the FEZ connect and then using a wifi module with that or ismply straight onto the panda but now I am having doubts.

Any recommendations for other micros o will the Panda II be able to handle what is to come?
What about the FEZ Spider?
Alternatively I could go with a STM micro as that is where my experience lies as it stands.

The problem is that you are using a device that was made LONG years ago and discontinued about 3 year ago. If you use any of the current devices you will not have problem with documentation. Now, your old FEZ Panda will still work, and you are half way there, but it will be a bit difficult to use.

My recommendation, keep the FEZ Panda but also order a new FEZ Panda III. Once you have experience with NETMF using FEZ Panda III then it should not be too hard to go back and use the FEZ Panda for other projects.