Main Site Documentation

Starter Kit Arrived Today but USB Driver Does Not Install :(


#1

Hi,

My starter kit arrived today in the UK, fast-tracked by Fedex.

However the USB Driver does not install, no matter what I do; can someone please help!

I have Windows 7 Professional on a X64 Machine, naturally I thought perhaps that I needed the latest Firmware but naturally I need the USB Driver even for that!

I have reinstalled the Gadgeteer download from Codeplex, and I also have Visual Studio 2010 Professional.

I’ve previously been running Netduino off the same USB port so I know that its not my hardware playing up!

The error is: One of the USB Devices attached to this computer has malfunctioned, and Windows does not recognise it.

USB Root Hub (2 Ports)
= Unknown Device
= Unused Port


#2

Do not make it hard on yourself! Go to the Downloads&Tutorials section here and download the latest SDK from GHI. It has an installer that will install all the parts you need automatically.


#3

Hi Jeff,

Thanks for the advice, which I promptly did, unfortunately with the same result.

I did notice in step 4 that it was installing the x64 drivers, so that pleased me.

However once again the result is the same, so I’m lost without help.

(As an Engineer I’m quite a patient chappy as we’ve all been around this block before … but I must say, I can’t wait to get this up and running ;D )


#4

Does it act like it is installing the drivers but it just does not recognize your device when you plug it in? Are you getting any sort of error mesage?


#5

I get the USB Not Recognised balloon as per the attached jpg

(Thanks for your help!)


#6

In addition, I’ll add a shot of the next screen (from clicking on the above balloon!)


#7

Did you plug into an USB hub port? If yes try to plug in direct to the computer or a powered hub.

I do not have a Gadgeteer but have seen this behaviour with the Cobra with the LCD plugged in and using an USB hub.

HTH.


#8

You shouldn’t do that, instead use the GHI installer only as suggested by Jeff.

Now, about the problem, did you try to connect the USB directly to your PC, no hubs? Maybe try to use power pack to power up the board…read about this and a lot more here http://wiki.tinyclr.com/index.php?title=Gadgeteer

Welcome to the FEZ world and to our community :slight_smile:


#9

Hi, I plugged directly into the laptop, I’ve got 3 USB ports so I have tried all three.

Btw, as you have mentioned power, perhaps I should get a powered hub, if there’s a 20% chance of it getting me out of this nasty position the expense is worth the risk, do you think it is worth a stab in the dark??


#10

In my opinion, everyone should always use powered hubs and only powered hubs. This will keep your PC/laptop safe from any problems relating to the devices you plug in.

Have you tried another PC?


#11

Before you run off to get a hub you should try to power the Spider USB Client DP module with an external power source (wall wart, bench power etc.)


#12

Thanks Gus, I just picked up on your response and having read the wiki I’ve decided to purchase both a Powered Hub and a power pack, I guess both will come in useful sometime anyway (a chappy can never have too much kit).

It’ll be 24 hours until I get the chance to purchase and load these, thanks in the meantime!


#13

Thanks Rajesh, your reply came whilst I was responding to Gus.

I think what I will do is purchase both as if one doesn’t work I will be able to try the other instead of wait another 24 hours.

I’ll give feedback one way or the other tommorrow.

Thanks again!


#14

Problem solved!

It occurred to me overnight that I had an external hard drive fitted with a dual USB cable that luckily for me had the right connector to plug into the Spider’s power module.

So I unplugged the external hard drive, plugged in the Spider power module, and hey presto that beloved balloon appeared saying that GHI’s drivers had installed correctly.

Works like a dream!

But now I have 8 hours before I can play with it!

Thanks guys!

;D

PS to Gus:

Hey Gus, it wouldn’t hurt to add a comment to the wiki about a dual USB cable being the minimal USB only power config (I’ll cross the LiPo bridge when I get to it) ~ and hey, what about adding such a cable to the shop, isn’t sales really all about ‘the add on sale’ :slight_smile: besides, if its in the shop then people like me will buy it with the kit because as all ‘Embedded Geeks’ like me know, you buy stuff just because its there :smiley: (as demonstrated by the other stuff I bought when I bought my kit).

Cheers!


#15

A dual USB cable is a hack. A powered USB hub is under $10 on eBay and will improve all your USB devices. And will keep you pc safe.


#16

It continues to amaze me how non-standard many USB ports built into PCs are. They should be able to provide 500ma but many can’t. Then to compound the problem most USB cables use 28AWG wire for power and the voltage drop across a 2m cable is bad enough that many devices won’t work properly. I’m with Gus on this one, a powered USB hub will solve many problems on the average PC.


#17

You know, it never occurred to me that the wire is such a high awg. Manufacturers don’t publish that info, of course. Has anyone found cables with a lower awg?

This may explain a problem I have with my USB-powered mic from time to time. It is VERY picky about the port it is plugged into, and it also seems to hate my (powered) hubs.

Pete


#18

Take a look at: http://www.soigeneris.com/USB_Cable_A_B-details.aspx (my website.)

Several months ago I built a prototype stepper drive/control box for a laser micrometer system. It used two USB interfaced stepper drivers. I kept having strange issues with one drive or the other dropping out and after measuring the voltage drop across the USB cable it was clear why. I started looking around for better cables and found the cables above. For the production control boxes we added a few more USB interfaced devices so a powered hub was built into the control. The first production units have been out for several months now and working very reliably.


#19

Excellent, thanks Jeff

Pete


#20

Jeff,

Very interesting. Taig Micro Lathe II looks interesting.