STABLE 4.2 SDK release

Got the SDK installed on a Cerbuino Bee and deployed a 4 line test app with the LED7 module. Works like a charm.

@ GHI - Thanks for all the work on this SDK release!

I have update my Hydra and Cerberus with no issues. I am also very happy that I can now use the Cerberus without it locking up or causing BSOD. Looking forward to being able to use this board now. Thanks guys!!

Is the table at GHI Electronics – Where Hardware Meets Software up to date? I2C still locks up? Or does it work with this new version on the cerberus?

No it is not. All is there except ad drivers.

With new fw my Cerberus works better than before, but locks up again after about 7-8 debug (deploy) sessions. No BSOD at all for the moment.

I see that in 4.2 Hydra no more support to Native SoftwareI2C software in the Socket class.
I see that the code is in [em]Gadgeteer Src 4.2\Mainboards\GHIElectronics\FEZ Hydra\Software\NETMF 4.1 Firmware\DeviceCode\GHI_OSH_Drivers\SoftwareI2C\SoftwareI2C.cpp !?? [/em] …
In any case the SoftwareI2C class doesn’t work with Cyp6590 also in new 4.2 as it didn’t work in previous beta 4.2.

@ dobova - software i2c was never changed in any of the versions IIRC


Updating the Hydra is just connecting MFDeploy and choosing the right files, right? No need to use SD cards or shortening pins at the board?


Yes but this will only update tinybooter. I believe the wiki page is updated, yes no need for SD cards.

Gus, thanks

I think this [quote][/quote] is not updated yet, and if it is, there a requirement to either use SD cards or connect pins on the Hydra. This sounds a very not-straightforward process.

Where am I wrong?

Thanks again.

@ Gus - Thanks Gus, as usual, available at all times.

I try to explain better … sorry for my english :wink:

In 4.1 as in 4.2 the sw I2C is the same and it’s not working correctly with few chips from NXP, Microchip,Cypress etc … I noted in 4.1 that a Socket class on Hydra has a native I2C software driver (implemented in native c++) that works fine & fast. Now in 4.2 this is completely missed and the [em]Socket.NativeI2CWriteRead[/em] is null.

// from Socket.cs class
       /// <summary>
        /// NativeI2C functionality provided by the socket.  Null if not available on this socket.
        /// </summary>
        public SocketInterfaces.NativeI2CWriteReadDelegate NativeI2CWriteRead {
                return _NativeI2CWriteRead;
                if (_registered) throw new SocketImmutableAfterRegistrationException();
                _NativeI2CWriteRead = value;
        private SocketInterfaces.NativeI2CWriteReadDelegate _NativeI2CWriteRead = null;

I’d like to know if this is a bug or a choice not to implement anymore this fast native c++ driver.

I was unable to get the new Hydra Updater to find my device. I tried the old way (jumping pins 8 & 10 on socket 3) and by just following the instructions in the updater and it never would find the device. I was able to use the command line updater to update TinyBooter and then use MFDeploy to update the flash. Also, something that’s perhaps related… After uninstalling everything GHI then reinstalling the new bits, the USB cable/port was unable to detect any FEZ devices. Moving to a different port then allowed them to be found. I rebooted a couple times.

You are a FEZ hero with over 20K points :slight_smile: I am sure you can figure it out :wink: Funny I see you have problem updating hydra with every SDK release. You are either doing the same mistake every time or you have something wrong in the setup.

Spank! I think what Gus is trying to politely say is “Quit Yer Whinin”… Hah!

BTW - do we have to remember the special keys to get emoticons to work???

Just type them 8) :wink:

That would work if I remembered what they were…

I am sorry if sounded harsh but ianlee74 is one of the masters by now. He is even contributing the IO60P16 drivers, no newbie here

@ Gus - No need to apologize at all… I was razzing him, because you are right. Everybody needs a good spanking occasionally…

I got this message when trying to Deploy to Cerberus with latest Firmware.

Une exception de première chance de type ‘System.NotSupportedException’ s’est produite dans Microsoft.SPOT.IO.dll
Warning: socket 8 is not compliant with Gadgeteer : Cpu pin 4 must be specified for socket of type D
Warning: socket 8 is not compliant with Gadgeteer : Cpu pin 5 must be specified for socket of type D
Using mainboard GHI Electronics FEZCerberus version 1.1
Une exception de première chance de type ‘Gadgeteer.Socket.PinMissingException’ s’est produite dans Gadgeteer.dll

Check this thread:

Steven replied there about that issue.

Yea… Me & these updates don’t get along. Anyway, I did work through the problem and got the update on. I just wanted to report how I did it in case anyone else had the same problem. I’m still not sure why the new updater can’t see my Hydra. I didn’t have a lot of time to mess with it this morning. Unplugging other USB devices will likely fix it but it does seem like a bug that MFDeploy could see the Hydra but the Updater could not.