Main Site Documentation

SQLite and v4.1.5.1


#1

I am trying to use the SQLite database on the ChipworkX board. I have the latest firmware and sdk from GHI, and I can not get even the example code to work.

I can mount the NAND storage fine, it is formatted. I can create the Database object and open it, but as soon as I run the ExecuteNonQuery with the create table the whole system locks up. I have reboot the ChipworkX into tinybooter and erase the application using MFDeploy in order to get it back.

This is the first time I have tried using the SQLite database, so i have not tried this on any other firmware.


#2

Welcome to the forum!

What code are you trying to use?


#3

The sample code included in the GHI Electronics NETMF Library Documentation. Under Database Class


#4

Ok, good.

Now try to use RAM instead of NAND. Don’t mount NAND at all.


#5

Same results as before.


#6

How is you board powered?
Try to use external power source instead of USB or a powered USB hub.


#7

It was powered via USB, as that was convenient. So I added an external 12V adapter and I still have the same issue.


#8

Alright. I am running out of suggestions. ;D
I haven’t try db code lately. I will try it later tonight on my Chipworkx with the latest SDK.


#9

Thanks for the help Architect. Hopefully somebody from GHI will be able shed some light on my issue.


#10

Andy,

We have faced the same issue. We are investigating the solution.


#11

The bug will be covered in the next release.


#12

Hi,

I face the same problem that Nandy has. Can you tell more about the next release ?

In may case, I’m finalizing a prototype that I’m working on for several month, and I have the problem til I made the firmware upgrade to v4.1.5.1.

You can imagine the problem for me knowing that this prototype has to be integrated in a commercial product soon…

Thanks for your feedback


#13

You should lock on a certain release. For example, 4.1.3.0 seems to have no problems.


#14

I have a commercial version running, and decided to upgrade over the weekend.

Imagine my horror after hours of debugging, to find out i doesnt work.

How do we lock in a version that works?

and when do you expect a fix?

Alastair


#15

SQLite found to be broken on latest build, which we already fixed and will be online in few days.


#16

Are you getting any closer?


#17

SDK is done but with last minute issues it is being delayed. This is a top priority and we are trying our best.