Spider not detected on Win8 - May not be Win8 specific

Anyone else having any issues with the Spider on Win8? This is my Win7 machine (main dev PC with much Gadgeteer dev time logged) upgraded to Win8.

My Spider got bricked back at a local maker faire as I tried to do an update on it, but the internet connection crapped out, etc. etc.

Anyway, trying to get it working now. Tried different cables/hubs/etc. Hubs are powered. I installed the latest 4.2 bits today to see if that might do it. I also tried manually installing the .info in the SDK\usb drivers\bootloader (or similarly named) folder.

Device is detected in Win8, but the driver fails to start correctly. See screen shot. The firmware updater fails to detect the spider. MFdeploy fails to detect the spider.

I can boot it in TinyBooter mode and get the booter message on the screen. Not sure what if anything can be done from there. When I boot in bootloader mode I get a white screen.

The only modules connected are the client DP and the touch screen.

The Wiki tells me to pull out terraterm and a bunch of other ancient processes that really seem more for EMX than Spider (Spider redirects there but everything is EMX). Is that really what I’ll have to do?


“Keep fiddling with the switches” as mentioned in the other thread … worked halfway. Unfortunately, after the device restarted it failed and I got the big old “Updating failed!” message. The screen on the Spider showed the Tinybooter info.

Are the switches bad or something?


Win 8, USB3 - System Manager is showing EMX. MFDeploy doesn’t see it.

Spider, DP & T35.

@ mhectorgato

I got partway through the install. When device manager showed “EMX” was when the updater failed. I saw Windows trying to install a driver at that time too, and failing it appears.


When I installed the GHI SDK, each step of the way Win8 complained each step saying it was an unknown provider and that it was going to prevent it. I had to click more details and allow each step.

I’ve since replugged my device in with the switches set for updating and am now getting Unknown Device in device manager. I tried to uninstall the driver and manually tell it use the GHI WinUSB, but it doesn’t want to use that folder (C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\USB Drivers).

So I reset the DIPs to all pointing towards the button, and the device boots and runs my last installed app ok, but the Windows still doesn’t recognize it.

So flipping the switches a bunch and resetting a bunch of times (seems odd, but just doing a bunch of resets doesn’t appear to do it), I can get halfway through the install. When the board will work, the device in device manager no longer shows the little warning/broken symbol.

Anyway, I get through the install/update as far as putting on a new TinyBooter.

The Spider reboots and shows on the screen:

TinyBooter v4.2.0.0
EMX Build Date:
 Oct 24 2012 13:43:11

And then there’s some timeout and the FEZ Spider Mainboard Updater app responds with “Updating failed! Please click Start Over to restart.”

Edit: In Device Manager at this point it shows “EMX” with the little attention icon. That’s with all switches in the “default” position. Display shows the TinyBooter info.


That’s a totally different issue caused by GHI not signing the install packages. I actually took screen shots so I could send Gus and folks info on how to avoid that in the future.


Reconnected it once more and it again is showing EMX.

Bringing up the properties, it shows:
"The drivers for this device are not installed. (Code 28)

To find a driver for this device, click Update Driver."

Being insane, I did the same thing over again expecting different results – but this time I got just that. From that screen of the properties (instead of going to the Update tab), I was able to install the GHI driver! But the status is now showing:

"This device cannot start. (Code 10)

{Operation Failed}
The requested operation was unsuccessful."

Under “Debuggable .Net Micro Framework Device” I now have an entry of “GHI .NET Micro Framework USB Debugging Interface”, but it has a yellow ! icon.

Ok, so resetting the board over and over does actually change how it’s reported. Flipping the switches was a red herring.

On average, I had to press it about 15 times to get the Updater app to recognize it.

Watching the entry in device manager, it alternated between:
[ul]Unknown device (under other devices) with a bang warning
GHI Boot Loader Interface (COM3) (under Ports) with a bang warning
GHI Boot Loader Interface (COM3) (under Ports) without the bang warning. Usually, I can then reach the board through the updater. Not always, though.[/ul]

And after the incomplete update, I get “EMX” under “Other devices”, with a bang warning on it. Update fails.

Driving me a bit batty tonight as I needed to test some boards I built before mailing them out :confused:


You have multiple issues and this is why it is confusing. Please once you see emx, direct windows to the driver folder in premium SDK. You should be good to go.


Manually installing ghi_netmf_winusb.inf from
C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\USB Drivers\GHI_NETMF_Interface

Before running the firmware updater

Has fixed the problem.


1 Like

If you used the SDK in insider you wouldn’t have had problems

@ Gus

On Windows 8 you don’t get prompted to install a driver at that point. I believe this is because it tried earlier. Slightly different approach from Win7, so if you rely on that behavior, it won’t work.

Need to install the driver before doing the update. :slight_smile:


Yes, it is in the SDK found in insider :slight_smile:

@ Gus

Also good to know you have something in the works that addresses the driver problems.



Can’t mark my own post as the answer, but this is resolved :slight_smile: