Main Site Documentation

Spider load/stress


#1

I’m using a Web service polling scenario, which is basically this scenario: .NET Gadgeteer Relay Actuator via REST Web Service http://wp.me/p1TEdE-jF

The Gadgeteer application polls a web service for state information every 40 seconds. It sent a non-blocking http GET request on this interval but the system stopped working over night.

After running all night, the Spider is unresponsive. I couldn’t even re-deploy binaries from Visual Studio until I rebooted the Spider manually.

The WiFi module was still apparently working because a LED should have turned red on Network down, although the Network down event may have been missed for the same reason everything else was non-functional.

Does anybody knows what kind of limit this is hitting?

I have the application set to a 3 minute polling interval now to see if it can handle this over several hours.


#2

the state you described generally means the system has crashed after an exception.


#3

So it seem that a catch block, if I know where the error occurs, will solve this problem in the long running scenario.


#4

Try the Generic Exception Logger i published earlier today…
http://www.tinyclr.com/forum/1/6896/

it will allow you to log your exception to a Text File or post them to the web or whatever destination you like…

this way you can later inspect the file…

Cheers,

Jay.


#5

Thanks, Jay.


#6

Mike

Have you tried running for a long time while connected to the VS debugger?


#7

Yes, the device was plugged into USB and connected to VS when it hung. All I saw as a list of threads that stopped, not any exception output:
The thread ‘’ (0x4c) has exited with code 0 (0x0).
The thread ‘’ (0x4d) has exited with code 0 (0x0).
The thread ‘’ (0x4e) has exited with code 0 (0x0).
The thread ‘’ (0x4f) has exited with code 0 (0x0).
The thread ‘’ (0x50) has exited with code 0 (0x0).

These are the response received threads. Whatever went wrong to hang didn’t leave any tracks.


#8

What power source are you using when the device is working standalone?


#9

Now with the device connected to USB for power only, not debugging, it does not hang. It ran for 24 hours so far.
I encountered some very strange behavior when I tried to build in release mode! It messed things up so I could not deploy to the Spider board at all.
It took a lot of reboots to clear this up. I took out most of the debugger printouts and finally was able to rebuild in debug mode. Then I hooked the USB to another machine for power, without debugger running. It has been running ever since without problems.