Main Site Documentation

Spider hung after testing simple UDP code


#1

Hi,

I just had an interesting experience, I connected the J11D Ethernet module wrote 4 lines of code in the ProgramStarted function to create a UDP socket and send a single byte. On my desktop I have a little client App that listens for the data and displays it.

I ran the NETMF client twice and everything worked and then horror struck, my Display module just turned white and that was the end of it. I tried everything, but my PC was not seeing the Spider on the USB port.

I tried the following

  1. Switched between 3 different USB ports (1 on a powered USB HUB)
  2. Changed the spider to Loader mode, this did cause the driver to install when plugged into a different USB, but still the PC could not see the Spider.
  3. Rebooted the PC and tried 1 and 2 again
  4. Tried to run the firmware updater, but it just error’d out saying the device was not connected.

Finally, I went to the ‘Computer/Properties/Device Manager’ and disabled the GHI com port, which was at COM 5 a this stage, and then re-enabled it. Suddenly everything came back to life. I am not sure it this was just co-incidence, but it did seem to do the trick.

I saw that a few others have experienced this as well, but I did not see anything conclusive as to what caused the problem. So I hope this is able to help someone else or prove that it was just coincidence that the problem was resolved after the the disable/enable of the port.

Chris


#2

Remove the display for now. then try to force GHI loader. Do you see anything in device manager?


#3

Hi Gus,

The problem was resolved by disabling and then re-enabling the GHI COM Port, do you still want me to try this?