Spider Boot/Debug Issues - Help

I currently can’t get a Spider to debug or boot. Here is the issue:

When I deploy via VS2010 every thing is fine until the Spider roboots then nothing…my program does not run on the spider and VS2010 stops debugging. No errors, no warning etc. Just stops.

Here is what led up to it…

  1. I started using a Mountaineer board for a specific project with 4.2 QFE1 with success. Up to that point the spider deployments worked fine as well.
  2. I tried to switch back to the spider and deploy another project and it failed.
  3. I updated to 4.2 QFE2 and updated to the latest spider firmware.
  4. I updated to the latest GHI sdk and updated all USB drivers etc.

Nothing has worked so far.


@ Superpanda - You running VMWare on the PC?
Tried a powered hub?

Direct to Laptop USB. No VMWare. Deploy to Mountaineer board is fine. I think its more an issue ON the Spider because even though the deploy was successful, if I disconnect the USB from the Client DB and reboot the Spider…it does not boot fully. My program does not start.

Firmware update to Spider is successful and all communications with Spider from MFDeploy seem normal.


Oh Hi Justin…Sorry I responded like I don’t know who you are!


@ Superpanda - lol - no worries fella.
So you can’t even debug while usb is plugged in? Seem to remember someone else saying something similar but cant find the post at the moment…


I was referencing a GHIElectronics.NETMF… library…I can’t even find that one in the list so perhaps that was depricated.


PS Did that kiosk keep behaving?