Main Site Documentation

[Solved] Need help with "No Source Avaliable" - Error when debugging


#1

Hey,

I’ve just finished writing a long piece of code that looked, in theory, pretty good. All proud of myself I tried running it on my FEZ Panda.

Immidiate window is empty, thats strange - I have debugging messages all the way through…

Hit “Pause”, and almighty Microsoft strikes me with a screen I’ve never encountered before:

"No source avaliable

No symbols are loaded for any call stack frame. The source code cannot be displayed"

I’ve tried commenting out parts of my code, but its not going away. A simple debug.print(“hello world”) Will work, so the microcontroller isn’t dead.

I’m sincerely hoping you guys have seen this a million times before and can help me :).

CORRECTION: Hello world will work, but only when built from a new document. If I have just main() { hello world }, and the rest of my code commented out in my original code, it will still have no output and the forementioned error. How very strange :S


#2

You you have a DLL compiled separately that you are linking to your application?

Have you tried making new project and then add your source code to it? Maybe the project settings are messed up?


#3

I’ve just been copying the source into a new project part by part waiting for it to stop working.

It didn’t. It works.

I didn’t touch any settings, but something must have gone wrong. I blame microsoft :).

It would be great if there were some debugging suggestions for this error in the manual - Or at least the suggestion to start a new project. This has been troubling me for quite a while before I posted on here - I wanted to make sure I’m not doing anything silly before embarassing myself.

Thanks Gus


#4

Some things to try

  1. Try clean solution and rebuild all.
  2. Make sure in configuration manager all sub projects are in “debug”
  3. If you have multiple executable projects in solution make sure you load the right one

#5

Thanks Guys - Solved the issue just by using a new project. Nice to know for future reference though.


#6

Did you recently do a firmware update (ie an SDK update)? Or since you last did that project? Seems the classic firmware mismatch with existing project issue…


#7

Nope, everything s been done on the same SDK/firmware. Installed the SDK and firmware when I first got my kit, never touched it since.