(Solved) Issue with device not recognizing extended deployment

Edit - It’s working. Had the libraries and config rolled back, forgot about the project system. It’s working now.

I have had to revert to the last production release firmware ( to be able to get some critical fixes out to customers. However, I cannot get it to deploy anymore - it compiles and builds but now I get this message when it tries to deploy:

it’s telling me that it’s not recognizing the extended flash. Is there an in-code property that needs to be checked that i may have commented out on accident? I’ve tried it with multiple devices (one which hadn’t ever been upgraded beyond, and one which had been up to and then back) and both give me the same answer.

This could have something to do with the changes that were done to which part of the flash was used for what.

Can @Gus_Issa or @Dat_Tran confirm? Is there a way to reset the flash completely?

Make sure you are using the TinyCLR Config that came with the firmware. I got similar results when I was using a mismatched TinyCLR Config. I suspect that the location of these config bits is version-dependent.


Close - i did a dumb thing. I forgot to uninstall and roll back the Visual Studio project system. It’s working now, thanks for the tip.

Interesting, so the project system is also not checking the firmware version for compatibility with the config layout.