Main Site Documentation

[Solved] FEZ Config: "Device is not connected or not responding"


#1

(sorry if poor english, this is not my primary language)

Hi Guys

After successfull update of my Hydra’s TinyBooter, I updated TinyCLR in 4.2.6.2.
I checked “Ethernet firmware” since I intend to use the ENC28 Ethernet module.
Everything went well and when I connect to card to computer, it is detected as FEZ Hydra.

But when I ping the card, or check device for update with FEZ Config, I always get “Device is not connected or not responding” and the Hydra disappears from the drop-down list.
If I power on or reset the card, it is detected again but still does not respond.

I restarted from the very beginning two times (TinyBooter + TinyCLR) but I’m still stuck.
Any help would be much appreciated.

Thanks in advance

Edit: should I plug an Ethernet module before updating TinyCLR with Ethernet fimware?


#2

after firmware has been updated, enc28 module must be plugged in for the device to properly boot. if the enc28 is not plugged in, the device hangs.


#3

Eventually I updated the firmware without checking Ethernet option and the card could boot.
So you’re damn right! :clap:

Thanks a lot for your helpful reply.


#4

I reply in this topic because it seems that my problem is similar, but not equal.

I bought a Hydra few months ago (maybe about june 2013) and I was never be able to update firmware from original 4.1 to 4.2.

With the previous GHI tool (maybe GHI Config?) the firmware update procedure first make some write operation and then asks to reboot the mainboard and wait for 3 led blink. I tried this procedure many times, but I always seen only the initial led blink on reset…

Today I installed the latest GHI SDK and tried to use FEZ Config to update the Hydra firmware. I click on “[em]Firmware Update[/em]”, then plug in the USB cable (with USB client SP).
The combo labeled “[em]Updating devices based on[/em]” shows “[em]FEZ Hydra_Gadgeteer[/em]”, the “[em]The device’s firmware version label[/em]” shows “[em]Please wait…[/em]” and after few seconds a message box appears with the error “[em]Failure - Device is not connected or responding[/em]”.

No ENC28 was connected and the “[em]Check if you need an Ethernet Firmware[/em]” is not checked (anycase, I also tried to check that).

Thanks in advance for any help!

P.S. (Maybe that after those months of aging my Hydra becomes more tasty like a fine wine… :D)


#5

@ MarioDuz - If this document https://www.ghielectronics.com/docs/125/loader-tinybooter-update-fez-hydra doesn’t help, please carefully describe, step-by-step, what you tried and any error messages you received. Also note that with older boards and firmware, you should always update the loader (Tinybooter) before the firmware (TinyCLR). For Hydra you need to use the method described in the link above, for many of our other products you can use FEZ Config (under the Advanced menu)


#6

@ Jeff - Thank you very much for your quick response.
I have consulted many times the page you linked, because I think there is some step that I’m missing. I have choosed method 1 (NETMF app deploy) and reading “once chosen, do not use another method” I didn’t try any other methods.

Now I tried again with same method 1 and in the project Properties > tab .NET Micro Framework > “Device:” combo, there is only the “” entry.
If i click on the dropdown arrow, the VS UI “thinks” (freezes…) for a dozen of seconds and then anything changes.
If it can help, FEZ Hydra entry appears on USB trayicon on Windows taskbar.

Thank you again for your support.


#7

@ MarioDuz, welcome to the forum.

It is unlikely that you can use Method 1 - please see the “tip” at the top of that section. I would always attempt to use Method 2 as first preference, since it relies on you having the device and a paperclip or similar, much more likely to succeed.


#8

@ Brett - I definitely won the booby award of the year! :smiley:

I had read the tip last year, but having just bought the mainboard I did not think it was my case, and despite now having re-read several times the page I do not pay attention to that tip anymore… :frowning:

Hydra up and running CLR 4.2 ;), I glued the paperclip on my knees and I will do penance for three days! :slight_smile:

Thank you all for the help…


#9

no need for penance. just make cool projects :slight_smile: