[SOLVED] comport starts outputting garbage after disconnecting usb


I have an application that relies on communication with a serial connection. It’s all working correct when my FEZpanda is connected to my pc, but as soon as I disconnect the usb the comport is outputting garbage. When I reconnect the usb connector the com-port is clean again (ps. I tested all 4 comports, they all act the same).
Anyone knows what I missed here?


Could it be an issue with voltage isolation of your COM port? I mean does the voltage level reference is the same between your COM sender and the Panda?

How did you manage the com port? is it polling? event based?

I’d pretty much agree with @ leforban, but I personally would first check your GND connections are consistent.

It definitely would help knowing how you’re powering the Panda, and what the device on the serial line is, and how it’s connected. I am also somewhat suspecting when you connect USB you’re also directing debug messages to the USB connection, and there might be some interaction with debug.print and exception messages, so can you tell us if your app does lots of debug output when you have USB connected (use MFDeploy to connect to the device and see the stream)

Problem solved!

It was a grounding problem. I was a little too minimalistic when I connected my ftdi chip to the fez panda, forgot to connect the ground. As long as I worked from an usb output on my computer that wasn’t a problem because the usb ports share the ground.

Thanks for your reply’s.

1 Like