Main Site Documentation

[SOLVED]Can't install the CDC driver on win7 pro 32bits


#1

Hi everyone.
We just received a Getac S400 laptopt preinstalled with win732 pro edition. We have tried to install the cdc driver but it fails. Device manager shows the CDC VCOM device but says that it can not find a good driver to install. When we point to the cdc.inf file it says the same thing. No suitable driver found…

In fact the inf file refers to usbser.sys that does not exist inside system32 folder…

Any help will be appreciate


#2

In 4.2, support for CDC Class was dropped, and the class was marked obsoleted, however the obsoleted tag was overlooked when generating the documentation. We are working on fixing the documentation as we speak.

However, if memory serves, you prefer to use 4.1, unless I missed you journey to upgrading to 4.2 (or maybe my memory just doesn’t server well in this event lol). If you are in fact still using 4.1, then there is a possible work around, just trying to locate one from a trusted source.


#3

I am using 4.2. I hope that CDC has been marked obsolete due to the fact that CDC+ debug disappears… No do you plan also to remove cdc entirely? I guess no

It works on desktop with vista but on this laptop (the customer one) we can not install the cdc. and I don’t know what is wrong. Do you have a step by step process to install it?


#4

@ James - you are confusing two current features, CDC is supported.


#5

Solved… this was a stupid reason… my colleague saves the file as CDC.inf.txt and the extension was not show by seven