Main Site Documentation

[Solved] Assembly version problem


#1

Hi there,

I have a strange problem… When I try to add an assembly reference to my project (GHIElectronics.NETMF.Hardaware for example) I get this error : “GHIElectronics.NETMF.Hardware, Version=4.1.5.0, Culture=neutral, PublicKeyToken=null” is incompatible with .NET Micro Framework 4.1.28.21.0

I tried to download the .NET Micro Framework v4.1.5.0 but was unable to find it…

A strange thing is if I create a new project (into Visual Studio 2010) based on the “FEZ Mini Application” template, I have the FEZMini_GHIElectronics.NETMF.FEZ assembly (version = 4.1.5.0, while mscorlib, Microsoft.SPOT.Native, Microsoft.SPORT.Hardware versions are 4.1.2821.0) allready added but if I try to add this reference into a blank Micro Framework project I get the same error.

Does anybody see my mistake?

Best,
–Fabien


#2

Do you use Power Tools in your Visual Studio? Disable/Uninstall it.

Read here:
http://www.tinyclr.com/forum/10/2712/


#3

I do use Power Tools, and after disabling the “Searchable Add Reference Dialog” it works fine.

Thank you for you quick answer :slight_smile:

Best,
–Fabien


#4

Thanks Fabien, that works great. For others go into Tool->Options and look for the Productivity Power Tools entry. The configuration screen shown below.