Solution for: fez cerberus - stm32 bootloader booted, but not recognized in stdfutester.exe

Win7 64bit:

I had a problem updating firmware, despite trying to use the correct drivers, when plugged in while bridging the ‘boot’ pins on the device, it shows up as “STM32 BOOTLOADER” in device manager.

This is actually incorrect, it needs to literally show “STM Device in DFU Mode”, as in the
instructions. If using the STM32 BOOTLOADER drivers, the STDFU tester app will not pick up the board.

My win7 wouldn’t pick up the correct driver by default, so I had to force it to use the correct one from the STFU tester directory.

To update to the correct drivers, right click on STM32 BOOTLOADER in your device manager under “other devices”, click update driver, and direct windows to look inside “C:\Program Files (x86)\STMicroelectronics” (make sure to click the ‘include subfolders’ checkbox)

windows will pick up the correct driver for you, and it will start to work.