Main Site Documentation

Snap crackle and pop <- capacitors on the Motor board :(


#1

A friend gave me an RC battery that his v meter said was putting out 12.3v.

I briefly connected it to the Motor driver (not shield) and heard a pop. The caps were bit warm to the touch. So I reconnected my 7.2 v battery and the red light is not coming on.

The PDF say it can handle up to 30v, and the motor specs said it could handle up to 12v.

Did I fry my board?

:frowning:

** after a few minutes I tried again with the 7v and the red the came on :stuck_out_tongue:
:smiley: ;D :slight_smile:

The big battery pack can also put out ~8.4v I tried that and the red light came on!

Why did it pop before?


#2

You had the voltage reversed I am guessing.


#3

:-[

That’s a distinct possibility. Lesson learned.

It’s not working. The red light comes on, but the 2 motor lights in the front don’t & the motors aren’t turning.

Is it possible that chip got fried? It’s very warm to the touch now when I have even my lower powered source on it. Can I just get a new one of them?

:frowning: :’(


#4

Are the caps bulging?


#5

A bit on top … not exceedingly.

Any the GHI guys know what the farad rating on these are? I have some .3 uF ones.

Thanks

** editted to be more exact:
“330 uF, 35V, Electrolytic, Radial”


#6

It doesn’t say on the cap?


#7

hehe - don’t know why I didn’t check that <- I’m a software guy.

Can I try to replace them with the ones I have?


#8

These are the ones I have


#9

Yes you can but note the polarity. One side has a minus sign on it


#10

Well I may try it to work on my soldering ability. At this point, the board is effectively dead, so if this doesn’t do it, then it’s no loss.

I know the cap has 1 longer lead to indicate polarity.

Which direction do they go?


#11

Ah ha!

So the long lead goes on the + … correct?

(Thanks for the help!)


#12

yes long is plus


#13

Getting no love …

The lights in the back near the motor outputs don’t come on at all, nor do the motors spin up.

Thanks for the help though. The soldering was awfully sloppy - but got the job done. I had a hard time getting the leads into the board.

Eventually I need to get the super cool triple 'gator clips that MarkH is using in his Fez on Fire video with the Sharps.

Oh well … lesson learned.


#14

It looks like that chip is socketed. Can’t you just grab a replacement from digikey or something? I think the rest of the parts on the board are passive, but I don’t have a schematic to check.

Even if the new chip doesn’t work, you still have a spare H bridge (I would assume, haven’t looked up the part number).


#15

Yeah its a l293d. easy enough to replace. Just a few bucks at a electronic shop.


#16

Wouldn’t the chip need to be programmed? Or is that chip always coded for this purpose?

Regardless, where I live (near Daytona Beach, FL) it’s hard to find such things.

The one hobby shop in town (doubt they would have it any ways) closed up, only leaving Radio Shack, and they are so focused on consumer electronics.

If I get it on-line, then I have to pay shipping - so I’ll likely just get a new one from TinyCLR.

Thanks for all the responses!!


#17

Got my new board. I’m nervous - even though it likely my fault last time - to connect the power.

This pic is how I’m going to connect the battery to the board.


#18

Here’s the battery I;m going to use.

It’s 12v LiPo. I will use the main leads for the motor and use 2 cells (8v) via the 4 pin connector for my FEZ


#19

And here’s the volt meter verifying that’s it’s 12v (well 12.2) out.


#20

So it would be - (black) on the board to the battery black wire. Then the (white) + to the red on the battery.

Any thoughts?

Thanks for helping to calm my nerves.