Sitcore 13 series - cant find .native nuget

My new little Flea is having a bit of a time getting started. Using uart, signals, etc that need the native nuget installed. Installing one of these automatically installs native. version 2.1.0. The flea is running latest firmware . Running my program yields the following error:

Loading Deployment Assemblies.

Attaching deployed file.

Assembly: mscorlib ( Attaching deployed file.

Assembly: GHIElectronics.TinyCLR.Devices.Uart ( Resolving.

Link failure: some assembly references cannot be resolved!!

Assembly: GHIElectronics.TinyCLR.Devices.Uart ( needs assembly ‘GHIElectronics.TinyCLR.Native’ (

Error: a3000000

Waiting for debug commands…

Opening the nuget package manager, it shows native is installed, at version 2.1.0.

I have tried uninstalling all of the nuget packages, clearing the nuget cache, closing all copies of Visual Studio 2019, and then going in and deleting the obj, bin, and .vs hidden directories, then reopening VS 2019, and reinstalling all of the nugets, but still get the same error.

The only thing maybe a bit out of the ordinary is the intellisense is greying out the native reference, as if there aren’t any bits of code calling for it:

Is that the issue?

your image shows native as installed!

Did you try a new project? and then only add UART?
Did you try to completely wipe out your device “erase all”?

Thanks Gus - Erase all did the trick. The little guy must have had stage fright, it was the first application downloaded under the latest firmware.