Main Site Documentation

"Signature check" error when updating EMX to v4.2.11.1


#1

I need to update the EMX module to the latest firmware in SDK v. 2013 R3. This is the current configuration as displayed by FEZ Config:

Loader (TinyBooter) version information:
4.2.11.1 on this computer.
4.1.3.0 on this device.

The Loader (TinyBooter) not up to date. <<<

Firmware (TinyCLR) version information:
4.2.11.1 on this computer.
4.1.6.0 on this device.

The Firmware (TinyCLR) is not up to date. <<<

When I run MFDeploy to perform the update, I get: “Error: Signature check failed for file Config,sig”. See attached image. I am fetching Config.hex, Firmware.hex and Firmware2.hex from “GHI Premium NETMF v4.2 SDK\EMX\Firmware”. I can deploy the old hex files without any issues --it’s only with the new files that I get the signature error.

I would appreciate any suggestions. Thank you.


#2

Did you update the TinyBooter firmware before the TinyClr firmware?

If you have the latest SDK, then you should use FEZConfig to load the TinyClr firmware.


#3

I just tried updating the EMX TinyBooter with FEZConfig. I click Advanced > Loader (TinyBooter) Update > EMX (Fez Cobra). I set the file to: “GHI Premium NETMF v4.2 SDK\EMX\Firmware\TinyBooter\TinyBooter.GHI”. When I click Next, it jumps to the EMX Updater menu, which automatically fetches: Config.hex, Firmware.hex and Firmware2.hex. When I click next it returns this error: “The Loader cannot be updated if more than one device is connected. Make sure that only one device is connected and that it is in bootloader mode.” I don’t have other devices connected to the EMX. I am not sure how to put the EMX switches in Loader configuration. The document titled “Loader (TinyBooter) G120 and EMX Families” says “EMX: Ground pins 7, 3, and 53 then reset or power cycle the device.” I cannot locate these pins. I do have Up/Down/Reset…etc…buttons in the back of the board.

Any suggestions? Thanks in advance.


#4

Thanks. FEZ Config does confirm the device is in Loader mode although I still get the same error when I try to update TinyBooter. I am wondering though if the Invalid Signature error I get when updating the EMX firmware from 4.1.6.0 to 4.2.11.1 is actually caused by the TinyBooter.


#5

Yes, I uninstalled all the files. I just tried installing SDK 2013 R2, which is one version older than what I’ve been using, and I’m getting the same results. I wonder if the Loader error I get in FEZ Config is an issue with the USB driver. I read that there are different USB drivers which are being used. I am reading another way to update TinyBooter is via TeraTerm. I am connecting to COM1 and I’m not seeing anything from the serial port.

Baud rate: 115200
Bus width: 8 bits
Parity: none
Stop bits: 1 bit
Flow Control: none


#6

The EMX is now up to date. To update the TinyBooter, one has to power up the EMX while pressing Up, Down and Select.