Main Site Documentation

Servo Wiring Setup


#1

ive recently moved to working on the servor control for my GPS Pathfinder project and ive hit an issue testing the servo controller. i have the domino fully updated and it is connected (as seen in the wiring diagram) via the componant shield to the Serial Servo Motor Controller via the red white black cables.

i am using the following code in my little test app:

            FEZ_Components.Servo16 servo16 = new FEZ_Components.Servo16(FEZ_Pin.Digital.Di0);


            while (true)
            {
                // Sleep for 500 milliseconds
                Thread.Sleep(500);

                servo16.SetServoPosition(1, 5, 0); Thread.Sleep(1000);
                servo16.SetServoPosition(1, 5, 90); Thread.Sleep(1000);
                servo16.SetServoPosition(1, 5, 180); Thread.Sleep(1000);

but im getting no movement on the servo, almost like its not getting any power, but everything appears to be correct to me (a wiring noob). anybody got a guess?


#2

here it is


#3

website guy: sometimes the system doesnt let me upload files even when they are JPG and only 400k, that last one took 4 tries with no real reason before it finally worked, fyi


#4

Did you try the example in brochure and used the driver we provide? Did you step in code? Any exceptions?


#5

also why does the serial connector diagram appear to be backwards to how the connector actually plugs in? see how the wiring is black,white,red and the diagram is +,s,-?


#6

Gus: yes, this is from the brochure, with the driver added to the project, compiles fine, no exceptions when it runs, but it still doesnt work


#7

nothing? really?


#8

I must have missed this post!

The colors of the cables do not represent anything.


#9

If you look at the colors then they are wrong. The black and red should be twisted. Anyway. It does not matter which colors they use, as long as the cables are connected the right way to the servo. :stuck_out_tongue:


#10

well there is a power wire, a ground and a data wire, i know as long as the servo board and the componant shield are wired the same it doesnt matter what color the cables actually are, but i was thinking that with the diagram saying that, there maybe an issue somewhere (say if the connector had been soldered to the board backwards)

is anyone else using this servo control board? i am going to check the polarity coming out of the componant shield when i get home.


#11

um, silly question, but when was the last time you charged your 7v battery?

It happened to me this morning. It always happens when I’m working with servos. :slight_smile:


#12

contractorwolf;

Did you find out anything? If the ground wires don’t connect then the serial wont work.


#13

Indeed i did. it seems that the people who make the cable and the people who make the connectors are not communicating and got the order reversed. on the connector the place where the red wire goes in is the ground and the place where the black wire goes in is 5v, makes no sense but as long as its done incorrectly all the time it really doesnt matter.

the true nature of my problem actually turned out to be that the servo i got from tinyclr was bunk. when i plugged an old servo from another project into the servo control board and ran my servo test app it worked fine. plugged the parallax one back in and nothing. now, how do i do returns?