Main Site Documentation

Serial Woes - Revisited


#1

Hi,

I was testing a GPS module last night, everything was going well, I received GPS messages via RealTerm. I also tested output to RealTerm via COM2 of my Fez Domino, which also worked fine.

I played with the wires abit and now I can’t get the same results. I get nothing from the GPS module and get gibberish from COM2. (See attached screenshot) - Also I get the ERROR light turning on when bytes are received.

I’ve tried a few different things - trying another USB->serial cable (same result).
Connecting the GPS module on its own to the USB->Serial cable (no output).

BTW, if you don’t already know I have already rendered COM1 IN useless.

I checked the voltage at 3.3V and it is fine. I tried an onboard LED test on the Domino and that works fine.

Have I burnt something else out?


#2

I have also attached a picture of how I have attached the GPS module. You will notice that I only use the Domino to supply power in this situation.

The voltage drop over the 3.3V pin and GND pins on the GPS is 3.3V - So I know there is power going to it.


#3

I have also attached a photo of how I connected COM2 IN to the USB->Serial cable.


#4

Just throwing this out there…

It looks to me like a baud rate issue more than anything. Structured data, just mis-interpreted. Is it possible you’ve set the GPS device to a different baud rate? Is there a hard (hard) reset of the GPS to reset that stuff, and then try again in a known-working scenario connected the PC? I always like eliminating the Fez - it’s code that i usually bugger up!


#5

+1 on baud rate issue.

Also, what is the model on that GPS? Is it a 20033?


#6

What is the baud rate of your GPS?


#7

RJ, you’re on the wrong baud.

They are 19200, 8N1, configured for 1hz by default.


#8

Thanks for everyone’s help. The problem turned out to be the baud rate was not set correctly for the FEZ COM port and when the GPS was connected.

Also the GPS has a battery backup pin, which I didn’t think I needed to use, but I later found out that I need to expose it to 3.3V to get the thing started.

So, the baud rate when I had the FEZ connected had to be the same set in my code.
And the GPS was set to 9600bps.

I guess the reason I didn’t think it was the problem in the first place was due to my good old BBS days, when you would set the connection from your computer to your modem as high as possible. But obviously your modem would have a different connection speed between it and the other modem.

Thanks again for all the replies, I was thinking I had stuffed another pin on my FEZ. :-[


#9

phew ! The last thing we need is another dead pin or worse another fatality in the Fez Family !


#10

Ah right yes these ones are 9600, we used to get them on 19200. sorry.