Main Site Documentation

Serial debugging with Cobra II


#1

I try to debug my Cobra II via Serial, because I want to use the USB Client Feature.
I have a COBRA II Extender connected to the board.
The “Serial mode” pads are connected.
I have connected a USB-Serail module to port 5 which appears as COM4 in Device Manager.
When I connect the USB Client connector to my PC no device shows up in Device Manager anymore (which is correct I assume, because there is no USB-Client code on the board yet)

It’s a Cobra II NET, with FW 4.3 Beta 3 and nothing else connected, but power (15V DC) and USB-Serial module.

But when I try to deploy, I get the following error:

Looking for a device on transport 'Serial'
Starting device deployment...
Iteration 0
Opening port \\.\COM4
Attaching debugger engine...
... cannot attach debugger engine!

Any ideas what could be wrong.

Edit:
I even tried with a USB-Serial SP module, which was working for my Medusa Mini.
I also tried manually resetting the board while VS looks for the Debugger.


#2

Found it :smiley:

The program running on the board was using the GPIO’s from X5/COM1 as digital inputs.
By this no COM1 -> no Serial Debugger :wall:


#3

@ Reinhard Ostermeier -

Not clear about your issue.
If serial mode debug is active, I don’t think usb-client can be shown up…

Anyway,

if you are using Corba II, connect USB-Serial to socket 5, then gound the pin 2.1/Mode (socket 5, not com port 5)
It should work.


#4

@ Dat - My problem was that the program on the board was initializing the GPIO’s of socket 5. By this COM1 was not working.