Main Site Documentation

Serial Debugging Garbage Output


#1

I just got a Panda II. Hooked it up with USB, updated firmware, run programs, everything is good. But I want to use the USB as as host, so I followed the directions at: http://wiki.tinyclr.com/index.php?title=USB_Client to get into serial debugging mode.

However when I run MFDeploy and ping it over the com port (I’m using a regular RS232 cable and a RS232 shield to my computer’s COM1) I get mixed results. I’ve also tried using TeraTerm to communicate with the boot loader (ala the USBizi manual) and it works but with tons of garbage characters.

I’ve added screen cap of these two tries. Any ideas?

Also note: I’ve used this same RS232 Cable, shield and port on the computer to do serial debugging on a Netduino Plus.


#2

That looks like noise, most likely due to poor conducting of the GND signal. Make sure your cable has GNDs properly tied and not at all loose/dodgy. With DB9 type connectors, make sure the shielded cable is tied to the DB9 metal faceplate as well as the GND wire.


#3

Yeah, that was my first thought as well. But it’s a commercial cable (l-com) and in good shape. And I can flip back and forth between the Panda and my Netduino with consistent results. The Panda is noisy and the Netduino is fine.