Main Site Documentation

Send does not work on COM1 on the Robot Kit


#1

I’ve tried connecting COM1 on the RJ11 port on the robot kit to TeraTerm on the PC and unfortunately ran into some issues.

Sending data from TeraTerm to the device works fine.
Sending data from the device to TeraTerm does not work at all.

Initially, I played with various baud rates thinking that was the issue, but nothing worked (though the device kept receiving data just fine). Finally I broke out the oscilloscope. The RJ11 has 4 leads and only one of the them registered any type of signal (and only when receiving data). Sending data generated no signals on any leads in any way, shape or form.

This leads me to think that there any number of issues.

Either the Robot Kit has a faulty COM1.
Perhaps there is something special to initializing COM1 that I am not taking into account (just using standard SerialPort object with 115200,N81, no handshaking).
Anything else that I am not thinking about?

Any ideas on how to rectify the situation?


#2

You said you have scoped the pins and nothing is sent from your PC shows on the pins. Then you have a bad cable?

Is it RS232 or USB cable?


#3

No, I tested with the oscilloscope on the actual pins of the RJ11 (both inside the port and underneath it on the soldered connectors).

The cable is fine.


#4

Do you have a picture of the cable?


#5

I’ll take a photo of the cable when I get home. But, I doubt that the cable is the problem - I am not seeing any signals (using oscilloscope) on the device itself.


#6

I am trying to see what you have


#7

Gus, here you go.
http://imgur.com/7A9dp


#8

I doubted that if you need RS232 to TTL Converter or RS232 Shifter?

I’m not sure that if the Robot Kit already have the RS232 to TTL Converter on board??


#9

FEZ Mini has RS232 levels at COM1. ther is no need for RS232 to TTL converter.


#10

Add a 10K pull down resistor on TX pin form Mini. Now try to scope it and you will see something.

If you look at http://www.tinyclr.com/downloads/Mini/FEZMini_sch.pdf then you will see how the circuit relies on having an RS232 connection on the other end for it to work.


#11

Gus, are you saying that I need to apply a 10k pull down resistor to the other end of the serial connection? The other end is a comport on a PC.

Or are you saying that I need to apply this resistor to COM1 of the Robot Kit?


#12

Right on the TX pin on FEZ Mini board