Main Site Documentation

SeeedStudio WIZNET Ethernet Shield


#1

Has anyone had any luck getting the Wiznet Ethernet shield from SeeedStudio working?

http://www.seeedstudio.com/depot/wiznet-ethernet-shield-w5100-p-518.html?cPath=102&zenid=25bc5bfa8dfe6ff99178aeb0212356df

I’ve tried, but when I attempt to enable DHCP using Dhcp.EnableDhcp(), the method never returns.

Running the same code using my DFRobot Ethernet Shield works fine.

Any ideas on what might cause Dhcp.EnableDhcp() to never return?


#2

It is probably v5 shield. Read here:

http://www.tinyclr.com/forum/1/1439


#3

Oh, that one. You need to move the three jumpers. They are actually zero Ohmn surface mount resistors. The jumpers allow you to select whether you get the SPI from the ISP or the normal SPI1. While you are at it you may concider adding a jumper for INTR, id didn’t.
Once you move the jumpers it should work straight out of the box.


#4

Hmm… I didn’t know they have jumpers on that shield - good to know!

@ peddy you can always try it first by using wire jumpers from ISP to SPI1 pins.


#5

Just got in the office now, and am ready to give things a try. I’ll let you know my results.


#6

Everything looks good now. Moving the jumpers fixed the problem. Thanks for the help guys.


#7

Hi Peddy,
I have the same ethernet card from Seeduino and own a FEZ Domino.
I have tried the ethernet card as it is, and tried to run MSDeploy Network Configuration;it gave me “old or supported device” error.

I do not understand which wires you cut out and which ones you connected to get it working. I see in some posts that we are supposed to conenct ISP pins to D11,D12 and D13 pins.
How about the MISO or MOSI pins? Are they to be cut out? If so, from where? I see then conencted to ISP pins.

I would be greatful if you could provide me with a picture of your final solution.
Thanks in advance


#8

MFDeploy + built in TCP/IP is not supported on smaller devices. GHI provides W5100 support specifically fro smaller devices, see the free “internet of things book”


#9

Hi Gus,
Thanks for the info. However I still need to sort out my wiring I suppose.


#10

There is no wiring, as the picture above shoes, there are solder jumpers that need to be fixed correctly and that is all.


#11

You mean I take out the solder from MOSI,MISO and SCK on the ethernet board and connect ISP jumpers to D11,D12,D13? (I am using Seeduino card)


#12

Click on the picture in the post. You will see there are small black chips(zero ohm resistors) inside a red circle. You must unsolder those black chips from where they are and move them over to the empty spaces just left of where they are now…


#13

When the solder bits move over to the left , they get connected to the 3 pins on the left, I suppose. Because, to the left of the zero ohm value resistors, I see empty space and to the left of the empty space , 3 pins.