Main Site Documentation

Seeed SDK not installed on XP


#1

Seeed modules are not installed on XP using the GHI NETMF v4.2 and .NET Gadgeteer Package (11-29-2012).
“Install Seeed .NET Gadgeteer v4.2 SDK” is listed on the installer menu check list when installing on Win7 but not XP.
After installation on Win7 Seeed modules are available in Visual Studio and the Seeed Gadgeteer SDK folder is found in the Program Files (x86) folder.
After installation on XP Seeed modules are not available in Visual Studio and there is no Seeed Gadgeteer SDK folder.


#2

Has anyone else experienced this?

Has anyone successfully installed Seeed modules on XP using this release version?

How do I get Seeed modules automatically installed on XP using this release version?


#3

Very strange. Please try to reinstall again maybe?


#4

I tried a reinstall on the same machine and on a second XP machine with the same results.
Previous to installation I uninstalled all GHI, Seeed and Gadgeteer SDKs.


#5

What happens when you run the seeed installer itself? Look inside the folders one unzipped the package.


#6

I ran “Seeed NET Gadgeteer SDK v4.2.msi” from the Installation Files folder and now have Seeed modules in Visual Studio and in their folder.
Then I looked in the data.xml file and found the following xml for x64 Platform but nothing for x86 Platform.

  
<App>
    <Title>Install Seeed .NET Gadgeteer v4.2 SDK</Title>
    <Description>This step installs Seeed .NET Gadgeteer SDK.</Description>
    <Exec>Installation Files/Seeed NET Gadgeteer SDK v4.2.msi</Exec>
    <Optional>TrueChecked</Optional>
    <Platform>x64</Platform>
</App>

Guessing remove the

<Platform>x64</Platform>

for the Seeed install.


#7

Aaah! So I’m not the only one. Same here, as reported previously in an other thread, on WIN 7 32bit.


#8

yes,

try to replace by:

x86
or Any

It should work.
Thanks for your feed backs.


#9

To clarify, we have an error on our installer XML file. Will be fixed in next release.


#10

@ Armin: This is either funny or frustrating depending on how much sleep you’ve had. I read your post a couple of days ago and I knew that the Seeed SDK had disappeared on my installation also. When I finally had time to pursue it more I was going to reply to your post but couldn’t find it. I couldn’t remember the user name or post topic so tried searching for a while without success. This morning I tracked it back through your recent posts on your profile and saw the discussion on searching. Umm.

@ Gus: Good luck with the move this weekend. Hope you and the elves get some sleep.


#11

Change / to \ here:
Installation Files/Seeed NET Gadgeteer SDK v4.2.msi
gtx
dutzend


#12

Thanks and welcome to the community