Main Site Documentation

Sdk to install


#1

Hi,
which sdk should I install to see all the modules that I can use

Display CP7 Module
Display N18 Module
Display T35 Module
RS232 Module
SD Card Module
Serial-USB Module
.
.
.
.
.
Temperature & Humidity Module
Relay Module
RFID Reader Module
etc. etc.

I currently have installed:

.NET Micro Framework Software Development Kit
.NET Gadgeteer Core
Mountaineer SDK.

But I only see
buttonForMountaineer
ethernetForMountaineerEth

thanks
Scorpion1


#2

I use the ethernet mountaineer . NET Micro Framework SDK 4.2 (RTM QFE2)
not good.
I have installed il.NET Micro Framework SDK 4.2 (RTM QFE1) could not find anything
thanks.


#3

Don’t install QFE1 use just QFE2.


#4

hi,
I installed:

  • QFE2
  • ghi-software-package-v4.2-04302013
  • MountaineerGadgeteer42SDK

but do not recognize me my mainboard (gadgeteer mountaineer Eth).
How can I fix the problem?
I include photos for clarification.
what wrong?
Scorpion1


#5

Hi Scorpion,

I really don’t understand - what does your DESIGNER window show?

I’d suggest the best way for us to help you is for you to start a brand new project, and tell us everything you do. You should start Visual Studio, create a new project, select a Gadgeteer app, and then add your mainboard from the toolbox to the Gadgeteer designer. Please tell us then what is happening?


#6

Hi Brett,
The photo you see and that is generated when I do: New Project>. Gadgeteer net application (NETMF 4.2)
I press OK it generates what you see in the picture …

If there is installed QFE1 does not happen and it makes me work quietly.
But I also install all server components GHI in particular Sercam and ColorSense that with the QFE! are not there.
how can I solve the problem.
I installed it on my gadgeteer mountaineer
Mountaineer + Firmware + Update + to + NETMF QFE2 +4.2 + + (Ethernet + Mainboard)
http://www.mountaineer.org/resources/netmf-4-2-qfe2/ [line]


#7

I tried to uninstall and reinstall everything … but it is all the same


#8

in the designer, can you remove the mountaineer mainboard and add a different mainboard (say the GHI Spider)? Does the generated code then “look right” in the code window?

To use the GHI modules, you need to have installed the GHI SDK. That’s the only way to have that available under Visual Studio. So here’ what I would suggest (I haven’t done this, just suggesting you progress it this way).

First, assuming Visual Studio 2010 and a clean install (ie uninstall all the existing SDKs), install the Microsoft QFE2 package, as documented at http://www.ghielectronics.com/support/.net-micro-framework

Then install the Mountaineer 4.2 SDK from http://www.mountaineer.org/resources/

At this point, see if you can create a new app and see what the program.generated.cs shows, in particular whether the mainboard definition is added, and if it’s correct. Tell us what that shows, then quit VS (no need to save the app)

Then install the GHI 4.2 SDK from the GHI support page.

After that, re-do the test and see if the behaviour is different, and again tell us the result.


#9

I tried to change mainboard but generally always the same error.
I uninstalled everything.
I installed QFE2 and Mountaineer 4.2 SDK, in the middle asked me to install the core gadgeteer.
Done.
I created the new project and the error has not changed.

#error Please add a mainboard in the Gadgeteer Designer


???


#10

if I install the QFE1 instead of QFE2, program.generated.cs does not give me the error.
but I do not see the modules.


#11

hi
I formatted everything so we are sure that we start from scratch.
I followed all the steps that Brett told me, it works (I have no errors when I make new project), but when I install the 4.2 GHI exactly the gadgeteer core (version 2.42.7.00) sends me all wrong.
If I install the core gadgeteer (ver 2.42.6.00) does not generate the error but does not show me the forms.
What a strange thing …
How is it possible?
I have something in my pc that is not compatible?
PC:
Win 7
2 Gb ram
dual core E5500 2.84 Ghz


#12

I am not sure about the issue here but I know that QFE1 and QFE2 are not compatible. Especially that a change was done on the SPOT.Hardware lib, which changed its signature. This happened when adding Analog out, IIRC.

So if any device requires QFE1 then that maybe a problem with other QFE2 devices.

I do not have an answer but this may help everyone.


#13

There may be something different between 2.42.6 and 2.42.7 that is causing this. Don’t know what that could be !

Here’s a test I did on a Win8 machine (freshly installed on Friday). Installed VS2012. Installed 4.2 QFE2. Installed most recent GHI SDK. Installed the Mountaineer 4.2 SDK.

At this point, I could create new projects and use the mountaineer mainboards from the toolbox. Everything seemed to work; by creating a new app and dragging the mainboard into the designer, and then saving the designer window, I got the appropriate mainboard being added in program.generated.cs. Without saving in the designer, I noticed that the code was often for the older mainboard (I assume that the code update happens as a post-update task or something).

Please don’t waste time on QFE1 anymore - you can’t go back there, so there’s no point in testing it. Fundamentally you need the QFE2, GHI SDK, and Mountaineer SDK all installed, to be able to access everything that you need. Can I suggest a new install order - install QFE2, then the Mountaineer SDK, which installs 2.42.6, and then install the GHI SDK but do NOT install the Gadgeteer portion, and re-run tests.


#14

hi,
I followed the steps that Brett advised me, the only change I made is that I have not installed the latest GHI SDK but the previous “GHI NETMF v4.2 and. NET Gadgeteer 14/02/2013 Package” which has the core 2.42.600.0.
It all works
I use “Visual C # 2010 Express” Maybe this is the reason of my problems.
thanks very much.


#15

So it looks like the new Gadgeter SDK does not work with older devices.

I am not sure what is mountaineer plan for the new SDK. If you get an answer from them, please post here so we and others know.