SDK Package R3

@ willgeorge - You are in the wrong directory in you CMD session. You have to be in the location where the .bat file is or add that location to the PATH environment variable and then you will be able to call it from any location.

@ Architect -

Not sure that I understand what you said

Instructions show:

Step 1.

Navigate to “C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\G400\Firmware\TinyBooter”

That is where I ran CommandPrompt.bat from.

Slow brain here…

Look at you first and second images it shows that you are running it from c:\Windows\system32

@ Architect -

Thanks… How did I get there?

I’ll start over

Open command prompt and type

CD c:/your folder name/and your subfolders

Then enter the name of the batch file.

The command script that you’re running may not be written well.

Open the command prompt as administrator instead of using Explorer to do this… hit windows key, type CMD, then right click on the “command prompt” and say run as admin.

You should then arrive at the command line with c:\windows\system32 as your path.

type the following command…

cd “C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\G400\Firmware\TinyBooter”

then run

programg400.bat COMx

where X is the com port.

1 Like

@ Brett -

Thank you!

Except for a small spelling error it worked great…

programg400.bat COMx
to

ProgramG400 COM40 worked a bit better… Just funning ya!

Thank you for your help!

Not to knock the thread off topic.

Looking forward to the Improved premium CAN drivers for next release!

I vote for putting PPP at the top of the list to be added. :slight_smile:

1 Like

I’m in the southern hemisphere so everything is reversed, so P before C. :stuck_out_tongue:

Actually, I will be using CAN shortly with a project that also needs PPP so I would happy to have both as priority :slight_smile:

I’m using R2 atm and will install my device at the customer site on Monday.
Would any one say it is wrong to switch to R3?

Using G120, ENC28, SD

How is the suggested procedure to update the Tiny booter?
As far as I know it must be updated if there is a newer version.
But FezConfig can not update it!
I know that the old FW Update tool works, but this can not be the solution for the future. Or is it?

Which device? The tool already supports tinybooter update in this release.

G400, for example. How am I supposed to update tinybooter to 4.2.11.1? Please don’t send me here http://www.ghielectronics.com/docs/236/loader-tinybooter-update-g400 , it’s out of date — there are no executables in C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\G400\Firmware\TinyBooter

There’s just one file there, G400_tinybooter.bin. What am I supposed to do with it?

Looks like you need to reinstall the SDK. There are more than that.

Edit: See images in msg #25 earlier

https://www.ghielectronics.com/community/forum/topic?id=13692&page=3#msg139941

U just updated tinybooter for G120 from FezConfig… Menu “advanced” not sure if it works for G400

@ RobvanSchelven -

Update TinyBooter on G400 is not supported by FEZ Config, and g400 is not listed in there

Ok, reinstalling helped.

However, I still cannot update. The log pops up immediately with the following information:

-I- Loading applet applet-dataflash-sam9g15.bin at address 0x20000000
-E- Script File G400TinyBooter.tcl returned error : Error Initializing DataFlash Applet (Can't detect known device) - Error Initializing DataFlash Applet (Can't detect known device)
    while executing
"error "Error Initializing DataFlash Applet ($dummy_err)""
    (procedure "DATAFLASH::Init" line 14)
    invoked from within
"DATAFLASH::Init 0"
    (file "G400TinyBooter.tcl" line 19)
    invoked from within
"source $scriptFile"

How crucial is this TinyBooter update? May I skip it?

  • Power up G400
  • Disconnect all modules
  • Connect PA11 to GND
  • Press Reset button
  • Wait for few seconds
    => Should see new COM port under Device Manager (it must be GPS Camera Detect (COMx)
  • Disconnect PA11 from GND

Now update TinyBooter

  • Go to: C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\G400\Firmware\TinyBooter

  • Right click on CommandPrompt.bat,

  • Run as Adminstrator

  • Type cd C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\G400\Firmware\TinyBooter from C:\

  • Type ProgramG400.bat COMx (which COMx is the one shown under Device Manager)

  • Drink some tea and wait for few minutes

  • A notepad window will be shown up if it is done. if it is just few seconds, it means Error

  • Press Reset button then ready to use MFDeploy or FEZ Config to update it firmware