Main Site Documentation

SD card problem - IO exception InvalidDriver


#1

Hi everybody,
our customer just reported some issues with our attendance terminal which is built on EMX. They have 12 pieces of our terminal and there was no problem for two months, but yesterday, 4 of our terminals displayed error message when performing some IO operation (almost at the same time!). I know only error code of IOException, which is -520093696, which should be “InvalidDriver”. Can anyone tell what this error code could mean? Today another 6 terminals came out and I have still no idea, what’s going on… Can there be any issues with SD card (we use Transcend 2GB SD). I will be greatful for any idea…

Thank you
Martin


#2

I also found out, that the InvalidDriver errorCode is just following error because after first IOException I try to remount SD card. The first IOException ErrorCode value is propably -536870912 (Others). If just only one terminal stops work I would tell it’s definitely card and I wouldn’t bother you but 10 terminals out of 12 did it after two moths of continuous run in just two days :frowning: The strange is that after restart it works without any problems…


#3

Strange I observe the same thing yesterday on my module… Invalid driver. After reboot all was ok


#4

@ Marten - You need to repair SD filesystem probably on a Windows PC.

After a number of read/write for long time (for me it was less than a month) I found the same problem on G120 (Cobra II). It seems that I get better result in term of duration using Flush() on streams after any write. Other solution is to unmount and remount SD every couple of days. But still no error prone situation. This doesn’t change too much with different SD Brand and capacity.
I use Sandisk class 6, but Samsung, Trascend, Kingston get same result. Kingston class10 doesn’t work at all.


#5

This is interesting as it appears to be similar to what I was seeing with my Cobra 2 board although not the exact same error. My code stopped reading the flash with an exception part way through a file read but has since been fixed by a code change but this happened after it had been running for about 3 weeks non-stop.


#6

@ Dave McLaughlin - And do you remember what was the code change you have made?


#7

You’ll find it here under my posting about the issue.

https://www.ghielectronics.com/community/forum/topic?id=12329

Not sure if you are using the same command as I was?