Main Site Documentation

Screen displays ***** ASSERT *****. Board reboots


#1

Did not change any code, it was working fine. And today after board is powered up it shows up usual stuff on my touchscreen and right after “Loading” message from Glide the screen displays
***** ASSERT ***** and after about a minute board reboots.

What could be a problem and how I can fix it?

I cannot deploy anything to the board at this time.
FEZ Cobra III with Newhaven capacitive touch display.


#2

@ EvoMotors - try reinstalling the firmware.


#3

always check Device Manager as well, see what it thinks the state of the device is when connected to the PC.


#4

Actually I did changed the code, looks like in the last successfully deployed application the InterruptPort was instantiated with default port number (-1) because I forgot to set the port number


Cpu.Pin censorPortId= Cpu.Pin.GPIO_NONE;
...
...
...
InterruptPort censor = new InterruptPort(censorPortId, false, Port.ResistorMode.Disabled, Port.InterruptMode.InterruptEdgeBoth);

And I think this is why I’m having this issue. Is anything I can do to remove or replace the deployed app?


#5

I was able to update the firmware using FEZ Config, but it didn’t help.


#6

Use the MS deployment tool to erase the application for your device. That should do it. If you’re having issues because it reboots so fast here’s a trick I’ve used in the past.

  1. Bring up deploy tool and reboot device
  2. Hit erase button
  3. Reboot board
  4. Confirm erase dialog.

#7

The devise changes it state when reboots. The first several seconds after it reboots is available, but when program starts its changes to disconnected. I was able to put into the boot loader state several times and upgrade firmware but it didn’t helped.


#8

Was able to erase in the boot-loader mode!
Thanks!


#9

I can’t believe that it took me that long to hit this issue :smiley: :smiley: :smiley:


#10

us either ! 1064 Exp points when I posted this :wink: I think I’d done that in about the first week I had my first device


#11

It only took me 3 month :smiley:


#12

Hello!

I have this problem now.
I followed your remedy but doesn’t work.
So, I had the CobraIII running ok under debug, then today, I made some changes and
downloaded the application but ran into this hardware error and see Assert displayed on the screen.

I reset the board and from the fez config program, press the Erase Application button, then reset the board
again and when I see G120_G120 is connected in the lower right part of the config program, I confirm the erase.
I see it comes back with “The application has been erased successfully.”

But, I cannot ping it and still goes back to the “Assert” problem, so it seems like it didn’t really erase it.

When I reboot it, I see it shows the firmware version 4.3.8.1 and below that shows connected USB1, then
"Loading" but fails and comes up with Assert.
Does this mean it is toast and nothing I can do?

thanks!


#13

This is scary - everything is archived !!!

Anyway, in case somebody has this problem in the future, here is what I did to at least
be able to ping again, so I have hope I can reload my project.

I went back to a very basic project that only does a “hello world” print.
When I tried to run it, I still had the assert problem, however, when I
just did a build and then did the deploy separately right after reboot, it was able to
download the assemblies and now I’m hoping the problem is solved. At least I can ping
now, and looks like ok as I don’t see “Assert” on the screen.