SC13048 disappearing after putting in firmware

I received my new custom boards that have SC13048Qs on them today :slight_smile:

The SC13s show up fine while in loader mode, but as soon as I put in firmware rc1 or rc2, they disappear from device manager completely.

I can get them to appear again holding loader and resetting them, but they never appear outside of loader mode.

Windows also doesn’t make the device plugin sound when I plug them in. Only in loader mode

Any idea what this could be? Did I miss a pull up/down boot resistor or something?

The flea and pico work fine on my laptop, so I don’t think my laptop is the problem

That is possible. Or, you have a pull-down where a pull down should be. Or, a pull-up where a pull-down should be…

Hard to give a more precise answer with the information you provided.

Share a sch.

Anything is loaded beside firmware? Try erase all and load the firmware again, no application.

No, it’s just firmware. I tried erasing all and reloading the firmware, same result. No application present.

The 10K R20 resistor is the boot0 pull down, as seen in the SC13 dev board schematic

The pinout image of the SC13 is different from the PDF you get when you download it.

Picture on docs:


Remove the optional oscillator and let us know if that fixes the problem please.

You do not need to pull to GND. We do on our boards for internal reason but you do not need it.

1 Like

Why is it marked as pull to ground on the pinout then? :stuck_out_tongue: Seems a bit confusing :slight_smile:

I’ll remove the resistor and the oscillator and see what happens

It was forgotten. We will be updating it.

1 Like

Does the same apply to SC20100 ?

Removing the oscillator fixes the problem

you are welcome :slight_smile:

So, the oscillator is optional on SC13 and the loader does not use it at all. This explains why the loader works and the firmware does not. For whatever reason, the firmware is not happy with your oscillator.

BOOT0? or oscillator?

Can I try something to get the oscillator working? I need it for CAN.
This is the same oscillator as I use on SC20, it works fine there :slight_smile:

The BOOT0 resistor to GND, is it needed on SC20?

CAN will 99.9% work with no oscillator. But you should have an oscillator and it should work. I am also curious myself if there is something we can do to make it work on our end or you have hardware issue.

Our product has basically 100% uptime on the CANbus and we’re not using any external circuitry to make it work - what are you using the oscillator to do? Genuine question, figured if there is a better way to do what we’re doing it’d be good for me to know.

I am using the oscillator as main 8MHz crystal for the SC13048Q

CAN does error handling and resync to the bus automatically. You will just fine without crystal but the higher the clock and more picky you want to be the more you need the crystal. It depends on how picky you want to be.

Your schematic doesn’t show any capacitors to ground for the crystal so that is likely why it fails to start oscillating. The GHI dev board shows these to be 10pf. Check your crystals requirement.