Main Site Documentation

RTS and CTS on the G400 - RTS always HIGH


#1

Hi All,

Below is an issue I’m having with RTS/CTS on the G400. Hopefully its formatted well enough to be a quick read. Hopefully someone already knows the answer?

Project:
I’m using COM2 (Gadgeteer port 4 on Raptor) for a serial application with flow control.

Issue:
But, it seems that the RTS signal coming from the G400 is always high.

Testing
USE COM2 with and without flow control. You will notice that RTS (PA2) is always high.

Expectation:
It should go low when the module is ready for data (signalling that it’s “clear to send” to the other device).

Research:
I noticed this is an issue with netduino

And a mention to it being an issue in the smaller modules in GHI forums.
https://www.ghielectronics.com/community/forum/topic?id=10917

Resulting Question:
So, does anyone know if the RTS functionality works on the G400?

Thanks


#2

Read the release notes.


#3

Haha, and there it is.

Forgot to read the release notes. Glad you mentioned it.

Its kind of like standing in a grocery store asking where the drinks are while standing in front of the coolers…

Thanks Mike! Any idea if there is a change log or resolution schedule?

Answer:
Looks like handshaking is a no-go in 4.3 (2014 R5)

For anyone who doesn’t know what release notes Mike is talking about. This is what he is referring to:

C:[install dir]\GHI Electronics\GHI NETMF v4.3 SDK\Release Notes.txt

[b]Line 47 & 48:

Issues

  • UART handshaking does not work.[/b]

#4

Its also worth mentioning that, as it stands, the RTS should not be connected. Watch out when you make your PCBs:)

Reason being is, since the signal is always HIGH, your device will not respond unless you pull the signal LOW by way of a jumper or cutting traces on the board.


#5

@ rbrainard - I feel your pain, the IoT Labs WiFi module does not work with the Raptor for this exact reason. I’d like to hear from GHI on when this will be corrected.


#6

@ munderhill…guess I should have read your release notes too! :wink: I happen to have a Raptor and just bought your module. It’s no big deal though…no worries.


#7

If i understand well RTS does not work, is it also the same for CTS?

Is there any chance to have it work?

If no may I disable COM 2 and use these IO? Same thing for COM3?


#8

@ leforban - Handshaking does not work at all on the G400 in the current release, neither CTS nor RTS on any COM port. You should be able to use them as I/Os.


#9

@ John…what are the plans to address this major shortcoming?


#10

@ ibgregr - Like all issues, it will be corrected in a future release.


#11

:think:

Not sure and can’t take such a risk in my business. I prefer to consider it as not available.


#12

Hi John, do you have an issue tracker? It might help put people at ease if they can see that these issues are being cataloged and scheduled for specific releases.

Similar to what Netduino does?


#13

@ rbrainard - You can see the issue at https://www.ghielectronics.com/tracker/entry/73

It is a high priority item for us and we would like for it to make it into the next SDK, but no promises.


#14

@ John - Do you also have one for the Hydra+ as it does not work there either?


#15

@ munderhill - We do not currently have plans to support handshaking on the FEZ Hydra.


#16

Come on John… take a look at this face and tell me it doesn’t need handshaking.

This issue is effecting it’s BLE 4.0 communication skills…


#17

@ rbrainard - amazing :slight_smile: why not get on the phone and talk to John our anyone at GHI about your commercial needs?


#18

@ John - It is the Hydra+ and if you are not going to support handshaking then socket 6 needs to have the ‘K’ removed from the silkscreen and the specifications need to be updated (Socket ‘K’ removed).


#19

@ munderhill - The Hydra+ and FEZ Hydra run the same firmware so this applies to both. The specifications tab has been updated to reflect the lack of K support.