Main Site Documentation

RS21 causing reset


#1

Hi,

I’m having issues with my RS21 Wifi module, causing repeated resets of my spider.
I’ve got the latest firmware installed (today) - TinyCLR (Build 4.1.2821.0).
I’ve executed wifi.updatefirmware with a success indication.
I’m running from mains power.

In summary, when the rs21 module ‘wakes up’ and a green light appears, the t35 display whotes out, and the reboot sequence starts.

Any tips on troubleshooting this / validating what’ve got going on?

Regards
Rob


#2

Welcome Rob.

First bet: your mains power adapter is not up to the job. What power rating is it, and what’s it’s amperage?


#3

Hi Brett,

it is one of those universal laptop replacement power supplies, and is rated at 4.5A at the 20V setting.

btw, I’ve only got the RS21, the T35 and a button plugged intop the main board.

Regards
Rob


#4

Hello Bob. It is most likely a not enough power issue. Try another regular DC adapter.


#5

Thanks for the pointers.

What amperage and voltage should I be looking for?
Also, what is the mechanical / physical spec of the barrel connector.

Thanks agin
Rob


#6

Retried with a DC adapter rated 2A at15V with the same result :frowning:
Using .NET MF directly, things are stable until a .SCAN or .JOIN, at which point it resets.
i.e. .enable works, and the green light comes on, on the RS21.
Is there any troubleshooting I can attempt using a digital voltmeter and a nano DSO to see what is going on?
things are working fine with the J11D, running either with usb or dual usb and plug-pack.

Regards
Rob


#7

Hi,

I’ve now tried a third DC adapter (used previously to power a wireless AP), with the same result.
Any thoughts on troubleshooting this?

Rob


#8

What other modules are connected to the mainboard? Try it with only the RS21 module connected.


#9

Hi Joe,

Have tried with just power and RS21, same result, as soon as a .scan or .join is executed, a reset happens.

Rob


#10

@ Joe -
does the spider have an internal thermal sensor of some sort?

i think the spider (NXP) resets when it gets HOT…

@ mtnrbq - can redo your test and hold the back of your finger against the NXP chip and report back if it gets hot to the touch…

thanks.


#11

Would it be worthwhile to post the program being used to reproduce this problem? Could be an exception occurring.


#12

If you are doing an RTM Build then Mike might be right, it could be an uncaught exception…

or you can Debug using VS2010 and check the output window for any Exceptions… if it is an Exception it shouldn’t reboot while attached to VS2010 debugger, if it continues to reboot then it is something else…

thanks.


#13

Hi,

no noticable temperature difference during execution.

Regarding an exception, I’m stepping through the code in the VS2010 debugger, and as soon as a .scan or .join is executed, bam, it resets, i.e. nothing thrown that I can see in the debugger, the debugger loses connection to the device.

I’ll strip my code back to a minimum repro and post.

Regards
Rob


#14

Hello,

If you like you can send us you setup to test it out for you.


#15

@ mtnrbq,

Just a thought, are you using a standard RS21 with no antenna mods?


#16

Hi,

@ Joe, I’ll post the code and a pic of the spider setup - is this what you need?

@ Davef, no antenna mods, just as it came out of the box


#17

Yes the code and the picture could help.


#18

I’m using the code from the WiFiRS21Tester posted by Joe here: http://www.tinyclr.com/codeshare/entry/361

snippet (from program.cs) below: (line numbers added for clarity in comments)

1 void ProgramStarted()
2 {
3 wifi.UseDHCP();
4 //wifi.UseStaticIP(“192.168.1.225”, “255.255.255.0”, “192.168.1.1”);
5 string myAP = “nh”;
6 wifi.NetworkDown += new GTM.Module.NetworkModule.NetworkEventHandler(wifi_NetworkDown);
7 wifi.NetworkUp += new GTM.Module.NetworkModule.NetworkEventHandler(wifi_NetworkUp);
8 Debug.Print(“Scan for wireless networks”);
9 WiFi_RS21.WiFiNetworkInfo[] scanResult = wifi.Scan();
10 if (scanResult != null)

There is generated setup code (in program.generated.cs) for the rs21 module on socket 6

I can step though the above code in the VS2010 debugger, until line 9 causes a reset when executed.
If I use a static ip (i.e. comment line 3, and uncomment line 4), the reset occurs at line 4.
Manually creating a WiFiNetworkInfo item and calling .Join (not show in code above) also causes the reset.

Attached is a pic of my setup showing the RS21 on socket 6, usb and additonal power at the top of the pic, T35 and JD 11 disconnected.

Any further thoughts or test suggestions appreciated.

Regards
Rob


#19

A last thing, When you say it resets. How do you know that it is resetting, not exiting the application?

Could you please deploy the application then close VS and connect MFDeploy. Reset the mainboard then ping the device from MFDeploy. Then you will see the bootup information in MFDeploy till is reset/exits. Copy all the data and post it here.

Let me know if you need more information about how to do that.


#20

I’m at a loss - in a good way

Reset = same as pressing the reset button, connection from pc to spider disappears (i.e. not listed in MF Deploy until it has rebooted)

Trying the suggested approach yielded interesting results.
I refactored the code to move the interaction with the wifi into a button press handler and have the setup for that in the ProgramStarted.
Running from MFDeploy worked, wifi networks scanned, joined etc.
Went back to VS and single stepped through the code, all working.
Put wifi interaction back into ProgramStarted, still works stepping through from VS

Upshot - it is all functional now and i cannot get the repeated resets I was seeing before

Maybe a flaky connector or cable, who knows, but given how reliably I could cause the reset, simply by executing a .scan or a .join, and my inability to replicate it now, I’m at a loss. (I’ll video the next problem I have :slight_smile: )

Anyway, I now have a collection of power adapters, and a working WiFi module.

Thanks to all who made suggestions and provided theories.

Regards
Rob