Main Site Documentation

Rhino Issue - USB Device Not Recognized


#1

I was in the middle of debugging when my Rhino’s USB connection to my PC dropped. I tried cycling power and nothing. I tried using different USB ports and different computers but nothing happens when plugging it in. The board was connected to a regulated 6V source.

I disconnected the servo it was connected to and still nothing. This was the only device connected to the board at the time.

If I hold down the “reset” button I can get the PC to indicate “USB Device Not Recognized”, but nothing more.

The application that was on the device runs normally (moves servo back and forth on power up)

I tried getting into bootloader and I can NOT.

Any ideas? Do I have a dead board? Is there a warrenty?

-AP


#2

There is a MODE pin to set the board in serial interface. Make sure it is not connected to anything.


#3

I do not have and have not had anything on that particular pin…pin 36 on the board correct? It measures 2.7V.

Is this the expected behavior if MODE were pulled low?


#4

The pin defaults high is not connected. You can contact GHI directly for further assistance