Main Site Documentation

Resources.GetBitmap Does'nt Exist


#1

Hi

i tried to add resource from Resource manager and added some
Jpeg & Bitmaps to my projects and when i checked my
Resources.Designer.cs
there was only

    [System.SerializableAttribute()]
    internal enum BinaryResources : short
    {
        _1010601_10201567417644799_737177564_n = -19122,
    }
    [System.SerializableAttribute()]
    internal enum FontResources : short
    {
        small = 13070,
        NinaB = 18060,
    }

i use the latest version of SDK and Visual Studio 2012


#2

Welcome to the forum!

Images are included as BinaryResources. It is normal. Bitmap constructor has a version that accepts byte array. You can get binary resource as a byte array and pass it to the Bitmap constructor.

Edit:

Check this thread:

https://www.ghielectronics.com/community/forum/topic?id=13244


#3

Thank you Mr.Architect

indeed i tried to use BinaryResources but i got this error message :

An unhandled exception of type ‘System.Exception’ occurred in Microsoft.SPOT.Graphics.dll


#4

Try different image types (gif, jpg, etc.).


#5

@ Alir3za - If you wish to use the GetBitmap() function, then you will need to ensure that you are adding the resources using the Resources.resx file in the solution explorer and be sure to save the resources file after adding the files.

There is a little bit of magic that Visual Studio behind the scenes to only show functions for added file types in the Resource manager.