Main Site Documentation

Reset Cobra?


#1

Can I “reset” my Cobra?

Last days I had strange problems, it sometimes take very long time to deploy and debug code, I can’t get network to work. Ex If I run the simple “clock” code (MS sample) I get error “ASSERT” on screen when connecting network cable… I have had network working before.

Version say: 4.1.3.0

All ideas are welcome.


#2

Re-apply latest firmware could solve this. I had a similar issue where the cobra was not visible anymore when connected over USB.


#3

Same result, **** ASSERT ****

I run MFDeploy and just deployed (CLR, CLR2, Config) EMX files. Or must I do the tree button reset stuff?


#4

Yes


#5

OK, so I did a proper update of firmware, following GHI guide “4. TinyBooter And Firmware Update”.

All went fine with update of TinyBooter and firmware. BUT I still cant use network. **** ASSERT **** is what my screen shows after a few seconds (properly when getting IP address)

This is crap. What shall I do??


#6

So it was working fine before and now it gives these errors?
First, update your network settings using MFDeploy (MAC, static IP address…).
Then test a NETMF example as is. Do you get errors?
What example did you try so we can test it here.


#7

Yes Cobra and network works just fine before, only thing I have add a RFID reader (ID-12) to COM3 but I don’t see how that could affect this.

I have tried to set IP to static and enable DHCP with MFDeploy.

The example I use is “Clock” that comes with .NET Framework. Path: “C:\Users\YourName\Documents\Microsoft .NET Micro Framework 4.1\Samples\Clock”

Clock runs fine, but after a few seconds the app crash and display says with small letters ***** ASSERT ***** No error or hang in Debuger, just crashing the app.


#8

Can you remove the RFID and test it?
We need something to be able to generate the problem here so we can look into it…


#9

Hi,

I disconnected the RFID reader (nothing at all hooked up to Cobra’s I/O).

But I get the same error after a few seconds.

/Ken


#10

So you have cobra with nothing connected and then you see this error? This is good in a way! Email us your test application so we can run it on our Cobra to see if we get same results


#11

The example I used is from .Net framework samples, so you have that code already. Path: \Microsoft .NET Micro Framework 4.1\Samples\Clock"

But any code that use network will cause the problem.


#12

Networking is used enough with no errors. The problem is related to your hardware or your network settings. Also check your power source


#13

Did you try to enter the GHI loader and do erase all using E command?

If you tried this and last post then call the office and we will step you through it


#14

Please let us look into this and get back to you. If there is a problem, it is related to the time service driver. You can use all other networking functionality.


#15

Hi, sorry for late response.

Yes I did the E command when updating Firmware. I now power Cobra with USB and a 6V power supply.

Actually the Time example kind of work… Now the app freeze for 30 sec when calling “TimeService.UpdateNow” then I get the black screen with *** ASSERT ***, but after 30 seconds the app resume and display new time. (before I pull the plug when ASSERT was displayed)

So in a way it works but take way to long time…

Do you have any code example I can try on my Cobra for further tests?

/Ken


#16

I think mike found the problem


#17

There is a problem in the time service driver. You can use other networking functionalities. Try the client, server,http examples…etc
If time synch is a must, I think it can be done easily in C#.


#18

Sync time with NTP server: http://www.tinyclr.com/forum/6/1266/ (10th post down)
I use this on my Cobra and works really nice.


#19

OK I got http both as client and server to work and dhcp.

** post moved **


#20

Please make a new thread for other problems.
Make sure nothing is connected to the Cobra not even ethernet cable and do not put any software on it. Let it sit for 30 minutes. Does it get hot?