Releasing the NETMF and Gadgeteer Package 2014 R2 SDK!

@ Dave McLaughlin -

You’re best with the very thin enameled wire. You could drill some small holes to get to the other side.

It’s not much fun though.

Even worse when your eyesight is not the same as it was when you where 21 :slight_smile:

I’ll have a go at the first board this weekend. If that works I might be tempted to do the rest just so they are done and I don’t have the thought of doing them again later.

Very true! :slight_smile:

Well, this is not going so well. A few expletives have been used this morning with GHI being named along with them. :frowning:

Trying to solder even thin wire to a 0.5mm pitch pin is really bloody hard when 4 of them are next to each other.

Why can’t I have SPI option? cries :frowning:

F****… :slight_smile:


After 2 ***** hours I have given up trying to solder 6 bloody wires to that connector.

Thanks to the changes in the code I am now left with 4 useless boards one of which is now beyond salvage as the 200 pin connector is damage where I tried to solder the connections.

It would have worked if there had been tracks coming from those pins but as they where unconnected all I was left with was a tiny little solder pad. :frowning:


I think I am going to roll back to the earlier SDK where the SD was supported. I just hope that nothing else is broken when I do this.

Oh dear. Sorry that my suggestion caused so much trouble. It is possible and I have seen it done before, but the guy who did it had many years experience and some good tools.


Hi hagster. No worries.

Perseverance and another 2 hours and I finally got the wires connected but something is still not working as it still reports that the SD is not present so a little more testing to do.

I ain’t doing the other 3 boards though as it was too much hassle. :slight_smile:

Thanks for all the hard work GUI guys. We really appreciate your upkeep of the .netmf technology and we hope it brings the best rewards.


Hello everyone,
First of all congratulations on the new release…BUUUUTTTTTT…

the networking stuff changed and dlls have changed basically everything changed… which is fine… Buttttttttttttt …

Your docs here : and everywhere do not mentioned to which version the supplied code is for, is it for 4.1, 4.2, 4.3 the next version maybe 4.4 which is confusing the hell out of me and everyone else i’m sure…

now my question how do I create a simple GADGETEER Networking program with the built in Ethernet using a SPIDER… and one for the Cerbuino bee using the ENC28…

an up to date sample code please…
using the R2 sdk.



The ability to suppress the boot up messages appears to be broken at least on the Raptor. the following code does not remove it.

Does anyone know another way to remove the green boot up messages?


Add mentioned in the announcement, all docs are now 4.3

@ Gus - all documents tagged NETMF are for 4.3. Other documents don’t seem to be e.g. still refers to the depreciated .hibernate method.

Yeah :smiley:
I always assumed it would be posible already. I just were lucky to not actually Need it

I just installed it over Beta 3, it took less than 30 sec.! Is that normal?

In fact it was not really working when just installing the new SDK over the old one.
FEZConfig could not even ping the 4.3.2 device. Not via USB or Serial.
Updating the BootLoader over USB worked. then I could ping it over USB, but not Serial.

I uninstalled the SDK, rebbot install again, now both USB and Serial work well.

It is not tagged with netmf, is it? :slight_smile:

when using a spider with this sdk the following code causes the internal networkinterface to loose the IP address:

        // This method is run when the mainboard is powered up or reset.   
        void ProgramStarted()
            ethernetJ11D.NetworkUp += ethernetJ11D_NetworkUp;
            ethernetJ11D.NetworkDown += ethernetJ11D_NetworkDown; //+= Interface_NetworkAddressChanged;


        if (!ethernetJ11D.NetworkInterface.IsDynamicDnsEnabled)
            ethernetJ11D.UseDHCP(); this causes lose of IP Address
            Debug.Print("Program Started");

if I call UseDHCP(); will cause this code to always return for the IP when used from another calss…

        NetworkInterface[] interfaces = NetworkInterface.GetAllNetworkInterfaces();

                int cnt = interfaces.Length;

                for (var i = 0; i < cnt; i++)
                        var ni = interfaces[i];

                        Debug.Print(ni.IPAddress + "  and Interface index   " + i);
                        if (ni.IPAddress != "")                        {
                            return ni.IPAddress;
                    catch (Exception e)
                        Debug.Print("Error   =   " + e.Message);


If I remove the UseDHCP things seem to work but after about 4 to 5 minutes the spider freezes… the freezing happens while debugging with VS… I will switch to MFDeploy and see if that goes away…

@ Gus - it’s not immediately obvious what a ‘tag’ is in the documents section. I spent a little while searching for codeshare style tags. Just making it obvious to anyone else as simple as myself. :slight_smile:

The direct link was provided in the announcement :slight_smile: we are still working in cleaning ask other pages but for now only use the ones at the link provided please.

@ Jay Jay - Can you try to not use the Gadgeteer module and see if GHI.Networking.EthernetBuiltIn works?

@ wizard - Do you call GHI.Processor.Display.Save() after you set it to false? Something like:

public static void Main()
    GHI.Processor.Display.ShowBootupMessages = false;
    if (GHI.Processor.Display.Save())