Main Site Documentation

RelayISOx16 through Hub Ap5 very slow


#1

Hello.

 I tried plugging the Fez Lynx card to a USB 3.0 and does not work correctly, USB 2.0 works fine. is there any driver for USB 3.0?. 

 I am also working with Fez Lynx, "Hub AP5" and 2 cards "RelayISOx16" and noted that the activation of individual relays is very slow when I plug the card Relays to Sockets Hub, however when connected directly to the Fez works fast (but I need 2 sockets Y). Is there any way to reduce the time between activation of relays using the Hub card?.

 I modified the file RelayISOx16.cpp, removing almost all "system :: sleep (100);" (although I guess it's not recommended) but neither works. 

Any idea?

Thank you.


#2

I have a program that will activate 1 to 16 all relays, if I plug the card into USB 2.0 everything is fine, however if I plug in a USB 3.0 relays are activated in random order.

I think it sends information over the bus, some times matches the address of a relay, sometimes not.

by the time I got it solved by plugging it into a USB 2.0

#3

power issue with USB 3 socket?


#4

no, rather I think it’s speed problem.
may fail some parameter of the communication between Fez, Hub and Relay16ISOx16