RealTimeClock.SetDateTime(DT); hangs CerbuinoNet 4.3. Any work arounds?

I have a CeruinoNet running 4.3.
I Can read the real time clock but when I try and set it:


It hangs the board. I’ve seen many posts on the topic but no fixes that I could see.

Is there a fix for this?

Maybe due to not having clock or power on vbat? It has been years so I am not sure what circuit was connected. Please check the schematics.

HI Gus,
I’ve tried all the combinations.
Power to VBat yes/no and 32khz crystal + 2x6pf caps to D4/D5 + gnd. yes/no
No. Luck.
I suppose I was wondering if it ever worked? Or was this a defect that was never resolved?
I’ll retest the hardware…

Check your crystal soldering. And, does it return failed after few seconds or hangs forever?

Hi Dat,
I am using a CerbuinoNet board and soldered a 32khz crystal to 2 pin, connected two 6pf to those pins and added a ground lead to the two other ends of the caps.
I then plugged the 2 pins in D3 and D4 and connected the ground wire to ground.
I also have a 3V cr2032 connectedto vbat.

I noticed that the clock never ‘ticks’. Ie. it’s always stuck at midnight.
And when I try and set it, it hangs forever

not thread jacking, but perhaps the xtal is not matching the load caps? See Cerbuino RTC help - #18 by untitled (the thread went cold after that person went off to buy new xtal and caps)

1 Like

I found some old documentation about Cerbuino and RTC. I once ordered the crystal but then never tried to get it working. Perhaps it may help.


Thanks guys, Ill give that a go :slight_smile: