Raptor: SDK 2014 R5 Update Problem

I’m trying to get my Fez Raptor updated for the latest SDK, and having problems.

Updated Tinybooter to 4.3.6 with no problems.

Updated Firmware to 4.3.6 using Fez Config.

The first problem is that unable to use the “Check device for update” button to verify my load. I’m trying the following steps:

Reset board, wait for reconnect, then press ping. Response indicates it is in TinyBooter mode.

Reboot CLR, wait for it to complete, then ping. Response indicates it is in TinyCLR mode.

Press “Check device for update”. After a moment I hear the USB device connect sound, then I get the Fez Config “No response from device” error dialog. Press OK to remove the dialog box.

Ping at this point shows it is back in TinyBooter mode.

If I execute “Check device for update” at this point, the response shows that the correct version of TinyBooter is present., but TinyCLR is not present and the device in is TinyBooter mode.

If I go to the Firmware Updater tab, it shows that the TinyCLR version is correct (4.3.6).

The Second Problem is that when I attempt to Load the ENC28 config on the Network Configuration tab, the device appears to rest, I hear a USB device connect sound, and I get a “No response” error dialog. If I go back to the Connection tab and ping, it shows that it is back in TinyBooter mode.

Another symptom is that the board periodically resets on it’s own. If I try to ping I get a “Device is not connected or not responding” error.

Any ideas? I’m anxious to get this resolved so I can check out the new SDK.


Update: I reverted to SDK 2014 R4 and reprogrammed the board with 4.3.5. It works as expected now in Fez Config.

@ Randyrtx - Do you have any other Raptors or other boards that you can try?

@ John, no just the one unfortunately. I loaded a basic LED blinker application on it to verify after reverting to 4.3.5, so I think it’s ok.

@ Randyrtx - I was not able to reproduce any of those issues on the few Raptors I tried. Could you go back to R5 and see if they remain?

@ John, I reapplied the R5 TinyBooter update. It still has the same problem when using the “Check for device for update” button in Fez Config. I was able to get the network settings to work this time however. It shows the correct version on the initial screen for the Firmware Updater tab.

I am also able to deploy/debug in VS.

Prior to this, with the 4.3.5 Tinybooter installed, I updated only TinyCLR to 4.3.6. In this case all functions in Fez Config worked properly.

I’m able to proceed at this point, at least :slight_smile:

@ Randyrtx - We will keep trying to reproduce it and get a fix if needed, but for now at least you can move forward.

1 Like

@ John - Thanks!

@ Randyrtx -

Not sure it applies to your problem but I had an initial problem trying to update to the new SDK… I forget the exact details but I uninstalled SAM-BA and the SDK and reinstalled.

Everything worked after that.

It may have been because I noticed that the SAM-BA installer window was hidden behind the GHI installer and I did the SAM–BA next button at the wrong time (IF that makes any sense)

@ willgeorge - thanks for the suggestion. I tried uninstalling and reinstalling SAM-BA and the SDK, and the same symptom persists with FEZ Config. Otherwise, the board appears to be getting programmed correctly and works otherwise.


@ John - I tried the board on a different PC and FEZ Config works properly. It would appear something is wonky with drivers on the other machine (figures, it’s my main “workstation” laptop).

I’ll attempt a complete uninstall/reinstall of everything next. Deployment and debug doesn’t always go smoothly on that machine, maybe it’s related.

I have a problem with GHI FEZ Config since updating.

After losing HD I loaded VS 2013 and R5 on my computer.
I began having problems.
I tried a VS Ex 2012 with R5 and got same issues.
Screenshot shows no problems with chip i haven’t updated.

This is with 5 g400 SOM modules user deployment memory erased. Samba to 4.3.6 and FEZ config to 4.3.6.

If I jumper MISO pin on old SD header to ground I get Camera(Com3) and device is in fact in loader mode, and I can update loader.

If I plug device in using GHI development board device boots and Ping returns TinyCLR.
Click Update, device disconnects, 6-7 second pause device reconnects, meanwhile Fez Config gives Device failed to respond window.

Ping returns TinyBooter(in devices and Printers still shows g400, not camera com3)
Click update again and I get screen shown in scheenshot.jpg.

I rebooted CLR and then pinged device got TinyCLR message back.

If ping comes back TinyCLR then check for update disconnects USB and has no response window

After that Ping will return TinyBooter(Devices and printers still shows g400 connected)

If Ping returns TinyBooter(Devices and printers still shows g400 connected) Screen above shows.

After a while device resets itself and Ping will return TinyBooter

@ mPatterson557 - There are some issues with check device for update we are working on for the next SDK.