Raptor has died :/

Yes, the unthinkable has happened. My Raptor died just hours before the big demo, so … no demo. Luckily I have another Raptor. Still, it’s kinda depressing. I have tried:

[ul]Turning it off and on again ;)[/ul]
[ul]Disconnecting all sensors[/ul]
[ul]Replacing the (E)DP[/ul]
[ul]Replacing the USB-cable (from GHI and others)[/ul]
[ul]Holding LDR0 and LDR1 + reset[/ul]
[ul]Connect pin 8 on socket 3 to ground[/ul]
[ul]Tried another USB port with power (Surface Pro 3 dock)[/ul]
[ul]Another computer[/ul]
[ul]Other boards, like the other raptor, cerberus, etc. all work fine.[/ul]

The red LED lights up, and so does the blue one near socket 4. Current deploy on it doesn’t run.
The boards that do work, triggers the Windows 10 USB connection sound. This Raptor does not. The fairly common “usb not recognized” balloon does not appear. It doesn’t even register as anything in device manager. In other words, I think it’s broken, and it’s just ~3 months old. It worked great since I got it. Is it possible to get a replacement?

@ pantera9 - Did you ground pin 8 on socket 3 on startup and see if anything shows up in the Device Manager on that different computer with no modules except the USB DP/EDP connected? Did it work fine at one point and the next time you plugged it in nothing showed up? Does any part of it get unusually warm? Did you have anything connected that could have burned it out? Do all the connected modules still function with other boards?

@ John - Sorry for the late reply. Vacation time…

Yes, I did ground it with no modules on a different computer, but I didn’t check if it was hot. I’ll try on yet another machine and get back to you on that one. It never worked after initial fail on the other computer. It did get power though, and the red and blue leds were lit up (as seen in the previous posted picture). Software didn’t run as far as I could tell.

I don’t know if anything could’ve burned it out. I have several breakouts connected with: temperature ds10b20 with 4k7 pullup and Pololu Qik 2s12v10 (note that feedback is not connected and it gets main power from external source).
Through power extender module: actuator potentionmeter PA-14P and GPS LS20031.

This setup worked fine for a couple of months, sometimes several hours a day.

All the modules and external breakout sensors work fine with the new board. We’ll see if this lasts.

@ pantera9 - Once you find out if the module is hot, contact support @ ghielectronics.com and reference this thread.