Main Site Documentation

Raptor G400


#1

Trying to see if I can run TinyCLR on a Raptor. I see some info on using the bootloader to update the firmware, but when I click on the links it either goes to a blank page or a 404. Is it possible to update the firmware on a Raptor and start programming in TinyCLR? When I launch TinyCLR Config it is all greyed out whether the board is plugged in or not. I see instructions for using Tera Term, but when I launch it, the serial section is greyed out.


#2

G400 (that Raptor uses) is on the supported list of 0.7.0.

http://docs.ghielectronics.com/tinyclr/downloads.html then follow along in
http://docs.ghielectronics.com/hardware/legacy_products/gadgeteer/fez_raptor.html

Please be clear what step you believe has failed, in what page.


#3

Hi Brett. I don’t fully understand the process, but I believe I need to install the Bootloader v2. But when I go to Raptor page, the second page you have listed above, and under the following section,
“Loading GHI Bootloader v2”, it says “Follow the exact same steps found on the G400 page”. When I click on that link to the G400 page, I see a blank page. http://docs.ghielectronics.com/hardware/products/scm/g400s.html


#4

There is also this post in the Announcements section about adding the G400 to TinyCLR. Re-adding G400 to TinyCLR OS It has a line that says “For help on updating the bootloader on your G400, take a look at our new docs19.” When you click on that link it goes to a 404. http://docs.ghielectronics.com/hardware/products/ucm/g400.html#loading-bootloader-version-2


#5

Sorry about that. We are still refactoring the new docs. Please see this http://docs.ghielectronics.com/hardware/products/ucm/g400d.html

By the way, the way you load the new loader is the same way this worked before, if you have done it before.


#6

I have done it before, but it was quite a while ago. > a year. I do not remember how it worked at this point. Thanks.