Raptor Emergency

To debug my RLP I put in an event. Nothing special. Just passing up an int value. The second I ran the code the board crashed. I’d love to remove that bit of code, the only issue is Raptor is no longer recognized as a USB device except in bootloader mode.

Have I tried reloading the firmware? Yes
Have I tried erasing the firmware and then reloading? Yes
Have I tried starting a deploy and then clearing the bootloader flag? Yes

Help. :frowning:

Oh, right. Erase -> Deployment, User Storage.

Thank goodness.

Back to work.

@ Skewworks - I am sure your know this, but we all need a reminder every now and then. The golden rule when using RLP - put a piece of managed code at the start that waits for you to press a button before proceeding. It makes recovery from a bit of bad code is much easier…


@ taylorza - Yes. Lots of things to remember like arrays being filled with noise instead of 0s .

Have the whole thing ported but its just spinning its wheels right now. Given up on tonight.

Should have an option to vote more than 1 like for this :))


Still working on this, I have a hybrid engine going right now to figure out why the full port is failing.

Another good tip: Replacing array[256][8][8][2] is NOT v1256 + v28 + v38 + v4 but rather v1128 + v216 + v32 + v4.

Yes, I know its basic math. Still worth placing a reminder for dumb dumbs like me. :slight_smile: