Main Site Documentation

Raptor does not connect any longer


#1

Raptor stopped connecting through USB. What to do?!

So… we had quite a fun playing with Raptor this Thursday and Friday, we were making new code, were pushing it to the Raptor, debugging it and doing it over and over again. We were running the project of USB and of of battery pack… until all of a sudden… after one of the code deployment it stopped connecting to our Surface all together… The code we have pushed was this:

            Debug.Print("Program Started");
            var ledId = 0;
            var flashDelay = 2000;
            while( true )
            {
                led7r.Animate(100, true, true, false);

                led_Strip.SetLED(ledId, true); // green, on
                Thread.Sleep(flashDelay/2);
                led_Strip.SetLED(ledId, false); // green, on
                Thread.Sleep(flashDelay);
                flashDelay = flashDelay-50;
                if (flashDelay < 100) break;

                ledId++;
                if (ledId == 7) ledId = 0;
            }

After reading now for about 10 hours this forum here is what I have tried to do:

  • got through two power hubs, with no luck
  • got USB power hub that says it can provide 900mA per port (Inhand 4Port USB 3.0 Hub MC 845503) still no luck.
  • tried 2 (two) other laptops to make sure that at list they can recognize that something is connected to USB, that did not help…
  • removed USB drives from my Surface and re-installed them again
  • sure rebooted Surface a few times during this time frame

Config that we had when it happened:
Gadgeteer side:

  • FEZ Raptor 1.0
  • Led Strip
  • Led7R
  • UC Battery 4xAA 1.0
    PC side:
  • Surface Pro with Windows 8 Pro
  • VS Express 2012 for Desktop
  • Microsoft .NET Micro Framework v4.3
  • NETMF and Gadgeteer Package 2013 R2
  • updated GargeteerHardware.XML in the C:\Program Files (x86)\GHI Electronics\GHI .NET Gadgeteer SDK\Mainboards\FEZRaptor

#2

An interesting find, is that when I connect TE35 display and power up the system I am getting following:

.on: 4.2.11.0
g:USB1
480x272
ting application at 0x00021000

Then after about a second of delay display shows irreconcilable blaberish in form of bunch of pixels.


#3

When I click reset button everything performs in exactly the same way, and it worth to mention that LEDs do nothing that we programmed them to do.


#4

reload the firmware


#5

Hi Andre,
yes, sure, here is the whole process:

  • First of all just o have a fresh start, I have restarted this computer, nothing is connected to any USB ports;
  • All Gadgeteer hardware sits quietly in the box, turned off, not connected to anywhere, for now…
  • Launch Visual Studio and wait until it gets to the Start Page
  • Click the New Project, navigate to: Installed\Templates\C#\Gadgeteer
  • Select “.Net Gsdgeteer Application”, leave everything else as default and click Ok.
  • In the .Net Gadgeteer Application Wizard, select FEZRaptor and click Continue
  • Wait until VS does it’s magic and created GadgeteerApp3 application with all underlying guts (screenshot#4)
  • From Toolbox drag and drop modules you will use, in our case it is Led_Strip and UC_Battery_4_AA
  • Then right click on the diagram and select “Connect All Modules”, behold it is all connected…
  • Save your solution just in case, and move on assembling your hardware exactly as diagram tell’s you (a little of course - thank you GHI and Microsoft)
  • Click “Alt F7” to get to the application properties, Navigate to .NET Micro Framework, select USB Transports, and select your device… But… it is not connected yet as we know…so
  • It is time to connect power HUB, ad make sure that it is working, by checking Device Manager, sure enough my new USB hub produces Windows connected chime, when connected. And Devise manager shows new device loaded.
  • When Ready connect your Raptor (great if you can hear Windows chime, because I cannot)
  • Then in VS change Transport to serial, hold on for a minute and change it back to USB. At this point you should see your device connected, in my case it was not.
  • Start FEZ Config, and try to ping the device - in my case it is not unsuccessful…

#6

When Windows doesn’t record a sound and doesn’t detect the device, none of the tools will detect the device. The thing to do now is to check Device Manager and find if there’s any devices listed that have a warning against them about a driver not starting.

As Mike says, you may have hit the situation where you need to reapply the firmware.

You will probably need to manually boot into bootloader mode and reapply the firmware from that point. Check the G400 steps:

https://www.ghielectronics.com/docs/236/loader-tinybooter-update-g400

And these also may be useful:
https://www.ghielectronics.com/docs/165/netmf-and-gadgeteer-troubleshooting
https://www.ghielectronics.com/docs/232/manual-version-checking


#7

Previous delete. Sorry, the code looked really messy…

As andre.m said.

For what it is worth:

I try to do as little as possible inside ProgramStarted() and wait for a button press before continuing.

If the button is not pressed it is much easier to get out of trouble.
Right or wrong it helps me.

Example


void ProgramStarted()
{
	Debug.Print("Program Started. Press button to continue");

	// Button module event
	button.ButtonPressed += button_ButtonPressed;
}
//

private bool isfirstpress = true;
void button_ButtonPressed(Button sender, ButtonState state)
{
	Debug.Print("Button pressed");

	// This helps to recover if something caused app to hang
	// Press button to continue
	if (isfirstpress) // If true continue
	{
		 InitMyApplication();
		 isfirstpress = !isfirstpress;
		 return;
	}
}

void InitMyApplication()
{
	 // Continue setup of your application;
}
//



#8

Thank you folks,
seems like the very simple answer from Mike “Reload the firmware” - is the answer.

Brett and Andre.M, yes you are right, the wild loop got too wild, it does not leave any breather for the board to communicate with the world out there.

And that is were Willgeorge’s suggestion to use button click events (which I completely ignored at first when read though troubleshooting manual) make a lot of sense.

…Reloading of Firmware begins now…


#9

Maybe it is time to start another topic on “Where is my ProgramG400”, but it make sense to keep all questions together until problem is actually solved-solved.

The same way as in the “G400 TinyBooter Update Procedure” post (https://www.ghielectronics.com/community/forum/topic?id=12290) on the step 3 of the firmware reload I am getting “GPS Camera Detect (COMx)” device on the port COM3. This is a good news…
However I could not find anywhere on my computer the ProgramG400, it is definitelly not in
C:\Program Files (x86)\GHI Electronics\GHI Premium NETMF v4.2 SDK\G400\Firmware\TinyBooter

Nor it is anywhere on my PC.

I have the FEZ Raptor Revision 1.0, I feel like for the next product I would need to join the BETA team :slight_smile: to have a jump start and extra goodies.

Now it seems like time to find out: Where is my ProgramG400?


#10

In all files that I have downloaded and extracted so far, I could not find the ProgramG400.

Here is what I have:

  • NETMF and Gadgeteer Package 2013 R2.zip
  • SDK.zip
  • FEZ_Config_v013.zip
  • GadgeteerHardware.zip
  • GHI NETMF Firmware Updaters.zip

There is should be a file somewhere, for now I am searching forum for a trace of it…


#11

Thank you Andre.M!
That was exactly what i needed. Raptor is up and running now.
Thank you everybody.