Main Site Documentation

Raptor dead?


#1

Hello,
I am still a beginner with the gadgeteer platform. I am not sure what happened with my FEZ raptor, the previous evening it was working great. The last project I made was a Wifi controlled car robot [schematic attached].

The next day morning, when i connect the Raptor to the computer, the power LED lights up but nothing else happen. No connect or disconnect sound. Device manager shows up nothing. Pressing the reset button does not seem to make any changes.

I tried the same USBClientDP with my FEZ cerebus and it works. So its not a problem with the USBClientDP module or the gadgeteer cables and The USBClientDP is connected to socket 8 of the Raptor.

I tried to power the device in the loader mode using jumper wires on Socket 3 directly on the cable [pin 8 and 10], but nothing seems to happen. [I do not have a breadboard module and I am not sure I am doing it correctly because I could not get it into loader mode even previously when everything was working]

Is the raptor dead? Is there anything else I should try?

Thanks in advance.


#2

I always make sure I disconnect everything except for the DP / SP power module and attempt to reflash everything at that point. Device Manager is the key - if nothing changes there, there is most likely something wrong at a hardware / cables level; swap USB cable and the one from the SP/DP module and mainboard.


#3

I tried removing everything except the power module and that did not help.
I can confirm that the USB cable, DP power module and gadgeteer cable from power to Raptor works because I tried the same on FEZ Cerebus and it was detected by the device manager.
:frowning:


#4

It might be the USB driver itself, try to connect the raptor to a different machine. Also try to uninstall everything from GHI or .NETMF and install it again after a restart. In rare cases windows updates or corrupted drivers can make a device not recognizable.


#5

And, hold LDR1 and hit the Reset button. The TinyBooter should be loaded.
If still nothing happened, as people here suggested, should try a different PC. Sometime PC can be confused about the drivers. :smiley:
I don’t think your G400 is dead.


#6

This has been frustrating… :frowning:

I uninstalled the whole NETMF and Gadgeteer Package 2014 R1 package from my computer and re-installed it. Still my computer does not detect the Raptor. My cerebus and spider works effortlessly with same power module, cables and USB ports. I also cannot start the Raptor in Loader mode.

I tried the same on a fresh computer and no changes.

@ DAT [quote]Although there are “LDR1” and “LDR0” buttons on the FEZ Raptor, they currently (as of NETMF and Gadgeteer Package 2013 R3) have no function regards updating TinyBooter. [/quote] Says the Loade r (TinyBooter) Update G400 document. Anyway, pressing the LDR1 switch did not help either.

Any other suggestions community members?

The Raptor is just about a month old and I bought it from shop.microframework.eu which is an authorized GHI electronics product supplier in Europe. In the event that nothing works, Should I be initiating the RMA with them or directly with GHI?

Thanks for the suggestions.


#7

When you say that you used jumper wires on socket 3 directly, what do you mean by that? Without powering the board, can you take a picture of what you did?


#8

Thanks Aron for your response.
I have tried many arrangements :

  1. Shorting the 8 and 10 pins directly [using a copper wire] of either socket 3 or 11.
  2. Connecting pin 8 and 10 using a breadboard wire on the gadgeteer cable which is connected to socket 3 or 11 [picture attached].

The jumper wire is connected after the board is powered up followed by pressing the reset button.
Or
Connecting the jumper wire before powering the cable and connecting the cable to USB port with the jumper wire on. In either case, the jumper wire is removed soon after [approx 3 sec] as in the documentation.


#9

@ deepakakkil - I believe that you are using the wrong pins to get it into loader mode. I am including images showing which pins you should bridge:

EDIT For the image with the cable, notice where the red wire is.


#10

Thanks Aron.
I did realize that I made a mistake when taking the picture. But I have also tried the pins u suggested. No changes!


#11

@ deepakakkil - I sent you a direct message, please see your inbox


#12

I had the very same problem. What I did is I removed all that relates to visual studio and all ghi software aand drivers and then reinstalled all those.
I also used ccleaner after removing all software.
I had similar problems with hydra at the past.


#13

Thanks for your message Jeff. Really appreciated.
I saw your message, but perhaps because I am very new here, It did not let me respond to your private message unless I have 100 points experience [eventhough I have 104 exp. now]! Is there some E-mail ID that I could use to reach you?

@ BlackDogSpark, Thanks for your reply. Because I have tried it on multiple computers, I suspect it could help. But I guess I will anyway give it a try and update here :-).


#14

@ BlackDogSpark, That did not work either. Meanwhile, I bought a brand new Raptor and it works [also in loader mode] with the current set up. I guess I should check the replacement policy as it still under warranty. Thanks all for your time.