Raptor bootloading problem

I took my raptor based prototype to a customer today and it failed to boot. Upon returning to my office, I determined that the PC could not see the raptor via USB. Therefore attempted to reload the boot loader via the G400 Bootloader Installation instructions. I was able to locate “Bossa Program Port” on COM7 but an External RAM initialization error was reported. I do not understand this error ofr how to resolve it. In addition the output indicated a log file was created, but I could not locate the file on my PC. I ran the “Flash Bootloader.bat” in admin mode. The output of “Flash Bootloader.bat” run is as follows:

The install process will take a few minutes. Once the install has completed successfully,
“Bootloader Install Complete” will be displayed. The "G400/FEZ Hydra Loader Updater"
must be installed for this script to function.

Please enter the number part of the COM port of the G400.
For example: enter only the number 10 for COM10.

COM Port Number: 7


-I- Waiting …
-I- TCL platform : Windows NT
-I- SAM-BA 2.12 on : windows
current connection is \USBserial\COM7, \USBserial\COM7 to be matched
-I- Retrieved arguments from command line :
-I- argv 0 : \USBserial\COM7
-I- argv 1 : at91sam9g15-ek
-I- argv 2 : Bootloader.tcl
-I- Connection : \USBserial\COM7 (target(comType) = 0)
-I- Board : at91sam9g15-ek
-I- Traces Level : 4
-I- target(handle) : 27220680
Read device Chip ID at 0xfffff240 — get 0x819a05a1
-I- Found processor : at91sam9g15 (Chip ID : 0x819a05a1)
sourcing device file C:/Program Files (x86)/Atmel/sam-ba_2.12/sam-ba.exe/…/tcl_lib/devices/at91sam9g15.tcl
sourcing board description file C:/Program Files (x86)/Atmel/sam-ba_2.12/sam-ba.exe/…/tcl_lib/at91sam9g15-ek/at91sam9g15-ek.tcl
-I- Loading applet applet-lowlevelinit-sam9g15.bin at address 0x300000
-I- Memory Size : 0x0 bytes
-I- Buffer address : 0x4
-I- Buffer size: 0x0 bytes
-I- Applet initialization done
-I- Low level initialized
-I- External RAM Settings : extRamVdd=0, extRamType=1, extRamDataBusWidth=32, extDDRamModel=0
-I- External RAM Settings : extRamVdd=0, extRamType=1, extRamDataBusWidth=32, extDDRamModel=0
-I- Loading applet applet-extram-sam9g15.bin at address 0x300000
-E- Error during external RAM initialization.
-E- External RAM access is required to run applets.
-E- Connection abort

You can find the above log at C:\Users\johnc\AppData\Local\Temp\GHI Electronics G400 Bootloader Update Log-18945-31.55.txt.

@ CDR114 - Has this specific Raptor worked fine up until this point or is this the first time using it?

Started to use this board in August and have been using it since as my primary development board. It has been running fine. My prototype system originally had the Hydra in it, but switched to the Spider II for commercialization and cold temperature specs. I have a Spider II prototype out at another potential customer site for testing and subsequently was going to use the Raptor for this customer demo. Tested the system Friday before packing the car and everything ran fine. However at the customer site on Saturday it failed to boot. Probably lost the sale until I can prove reliability.

My product is going to be low volume, so I was going to go with catalog modules and mainboards. After a year of development and another year testing, the only remaining step is to finalize packaging. However, with this failure and an earlier failure of a Cobra II board, my business associate is now also concerned about the reliability of the catalog components. Will they stand up to commercial use? Beside the mainboards, I am using the DP Module, the Xbee Module, the RS232 module, the SD Card module (which I have had a lot of read issues with) and the TE35 display. The product is to be used in outdoor sports timing.

@ CDR114 - Based on the error in the update log, the RAM is no longer working. Is there any physical damage on the board that you can see?

There is no damage, the Raptor and all associated modules and display were packaged in a 3D printed case. This case was wrapped in bubble wrap (pink) transported in box. The Raptor case is in the upper right in the attached picture.

John - I talked to an engineer today and he indicated that a contact pad on the BGA external RAM chip could have failed and if I wanted to he could reflow the board to see if it could fix the issue. He indicated that this would have a very low probability of success but he felt it was worth the effort since the board is not functioning. Do you concur?

@ CDR114 - It is certainly possible that a pad could have failed, especially if it has been sitting protected in a box.

Re-flowed and cleaned the Raptor and I am now able to install the bootloader and firmware with no errors. Once I get back to the office I will try loading my program. A connection to the BGA RAM chip must have failed.

Back at office and application program loaded and everything is normal.

@ CDR114 - Glad to hear you got it working. How long ago did you buy the Raptor?

I have the same problem as CDR114 but I don’t think the contact pad on the BGA external RAM have failed. Could there be an other fault?

@ lmu - We have not yet found any other causes