[qfe2] netmf 4.2 glide

trying to recompile my recently completed project using glide under the new netmf4.2 [qfe2] version and recive the errors seen in attached image, nt sure what is happening.

i have recomplied the glide project i had working with 4.2 [qfe1] and then referenced that dll in my actual user project, and i get the errors seen below. it seems that glide 1.0.5 requries some 4.1 references ??

when i look at the references in the actual glide project they are and not the version it says it is missing in the attached image, which seems to make sense.

tried donloading a simple new project with a led module which all works ok so i`m kinda stuck.

not really sure where to go from here, and help would be appreciated.

Try to remove/read references in Glide project and then rebuild it. Make sure you are adding rebuilded version in your user project.

the glide project is definetly trying to use the 4.2 references, see new image.

i have deleted all the file in the bin directory and rebulit the glide project to get a new dll, and then referenced that one in the user project and still get the same debug message as posted in the first post.

i`m guessing there is something i need to do with glide project itself, just not sure what that somethng is at the moment

Check project properties window

if it builds and deploy when using an Emulator then the project is ok… the error you are describing is similar to the one i was getting a while ago with my Spider…it may require you to re-flash your device firmware to get it to deploy…

1 Like

Jay Jay is correct. I have gotten the same error before and it is because your board is running 4.1 and you are trying to put 4.2 assemblies on it.

flashed the firmware today to latest qef2 version, mfdeploy confirms this, and a basic project with a led all on the new firmware deploys no problems, seems to me to be a problem with glide and the latest sdk, sure i`ll get it figured out thou…

thanks for the help guys, seems i was being a bit dim, once i had cleared out all the files from the bin directory and rebuilt the glide project it all works. i have updated my orignal project on code share with a new version that now works withe 4.2 [qef2] release.

Good. Glad it worked for you.