Main Site Documentation

Project - Game-O Emulator Community Edition


#1

I just posted Game-O Emulator Community Edition on Codeshare. Feel free to discuss and make suggestions here.


#2

Good one, thanks for sharing.


#3

You are welcome!

This will be next :wink: (need to clean code a little bit)


#4

This keeps getting better and better :slight_smile: When do you think you will have it ready? We are planning on posting an update on kickstarter so maybe we can include it.


#5

Is tonight ok?


#6

sounds great


#7

@ Achitect Is the start button not mapped in the emulator?


#8

It is available. You should be able to use it.


#9

I’m not able to get it to work, even in a very simple test program that just reads that button. What might I be missing?
I have looked over the emulator code and there are no preview mouse commands for the start button neither is it named start button - do I maybe have the wrong code? I may be way off base but, I just cannot figure this out??


#10

You may be right. I can’t check at the moment. But you can add it in the emulator. I will update the code on codeshare as soon as I can.


#11

That did the trick - I just had to name the button and add the mouse preview events.


#12

Excellent! What game are you making?


#13

@ Architect Sorry for the late response been out of town… I have just been messing around getting familiar with the the environment. I have built a simple line drawing program (kind of etch-a-sketch like), a shoot the enemy simple game, and I’m working on breakout like game. Nothing fancy - just want to get used to the way that NTMF is used. I’ve written a lot of C# but not in the NTMF.


#14

Great! Sounds like you are having some fun! :slight_smile:


#15

Looking forward to seeing what you’ve come up with!


#16

I have updated the project and added support for start button.


#17

Hi, I am new to working with device emulators. How can I attach it to Visual Studio Express 2012 for Windows Desktop. Or do I need to download a different version.


#18

I haven’t tried that particular flavor, but have you tried to build the project.


#19

Hi Architect,

The emulator build perfectly and starts (except for the notice that it misses what I am trying to execute.)

I have created a new Microframework Project for my game but then I can select the emulator.

But I am just wondering how to add the emulator. I do not seem to have the emulator device manager.

I saw that on the video on Kickstarter update that they seemed to be using the same version.

Thanks for your help


#20

@ s.j.w.vreeken - Good!

Now, create simple console app. Make sure the target framework is 4.2. Go to deployment section of the project properties. You should see the GameOEmulator in the dropdown of the available emulators.