Main Site Documentation

Project - FEZ Hydra Hacker Kit Preloaded Demo


#1

I just posted FEZ Hydra Hacker Kit Preloaded Demo on Codeshare. Feel free to discuss and make suggestions here.


#2

No video for this one either? :wink: Is it Pong also?


#3

No this one is combo - takes pictures and plays pacman. I will get to videos for both the kit demos. More complicated than I’d like for a [em]getting started[/em] program but does exercise a lot of features including Glide.


#4

Nice!


#5

@ ianlee74 - forgot to mention it plays FM Radio as well (need headphones or speakers).


#6

DOH! You just reminded me that I forgot to add a FM Radio module to my last order!

Nice demo! I see you have the video up now :slight_smile:


#7

Hello everyone!

New to the forum - new to Gadgeteer and electronics in general.

I’m not a total newb when it comes to C#…we use VS 2005 mostly here at work (that I’ve been at for 2 years now). But I ran into some issues when using this.

I purchased the Hydra/hacker kit from the Maker Faire, and the docs say to hit ‘the button’ to calibrate when it’s powered up. But there’s no button…the Pacman game starts up, as well as the radio on the left. But there’s no calibration screen. And the right side of the screen is blank…(just thought, maybe that’s the camera portion and I just had the camera pointed down…so totally fault on that one!).

I get the feel that someone already messed with this thing before me…for testing or whatnot.

So I decided to try and reflash it with the downloaded program. But ran into tons of errors on the build. It’s looking for a few references that I thought were already installed (I followed the tutorial to the letter, without any errors).

Any advice? My brain isn’t working as well today as it could be…so be gentle.
(added a pic of some errors…but I think one or two lines of includes will fix it up)


#8

@ verbosewater - Check out this documentation:

https://www.ghielectronics.com/docs/21/first-netmf-project

https://www.ghielectronics.com/glide/

You need to get the Glide code, build it, and then add references to it in your project.

Oh, Welcome to forums.


#9

@ verbosewater - a special version of Glide is included with the codeshare project. We are going to have to document the following:

In the Solution Explorer, remove the GHIElectronics.NETMF.Glide assembly from the HydraKitDemo1 project. The in the same References, Add, and use Browse to go up a directory and then down into the Glide subdirectory to find the Glide dll.

After deploying and loading you may have to reset the kit by unplugging power and plugging back in.


#10

@ verbosewater - Also, I recommend that one of the best starting points for the kit is to review http://www.ghielectronics.com/docs/43/first-gadgeteer-project. Documentation for each “module” is found on in the product catalog https://www.ghielectronics.com/catalog – each module product has a “Resources” tab, and for (where we haven’t missed it) there is a “Developers’ Guide” that, in many cases contains example code. I just noted that the T43 is missing its guide (I’ll fix that soon), but in the mean time, the Developers’ Guide for the Display CP7 overlaps material fairly well. Also, when working in the Visual Designer if you select a module and press F1, the API help will be shown.


#11

@ Jeff and Mike

Thank you for the info…I’ll be giving it a shot later today. It was also complaining about a missing reference for something in the dotnetwarrior project, but I’ll work through that one.


#12

@ Jeff and Mike
I’ve gone through several documents/tutorials you have posted, but none of them seem to talk about the includes/references. They go straight to the trenches.
This isn’t a complaint at all, just an observation. I’m ready to tear into this stuff and to get tripped up by these little things annoy me. And it may very well be my own fault. I can troubleshoot most things, but me and VS have never gotten along well.

Anyways, I’ve attached a screenshot of the last error. I still think I can figure it out - but any help would be great…as I’m typing this I just thought: maybe I just have to add the Glide project and compile it with the dotnetwarrior project too? (already did the Hydra one as you said) If so…any pointers?


#13

Some time the little things are the worst… anyway change the two “using” statements to:

using GHIElectronics.NETMF.Glide;
using GHIElectronics.NETMF.Glide.UI;

i.e. not “detwarrior.NETMF…”


#14

FYI, the demo program was designed to show off many of the capabilities of most of the modules in the kit. As such it is rather large & complicated for a first time project. I’ve put a top priority on creating a “how-to compile the demo code” document.

In the mean time, you can keep asking questions and we will help.

An alternative place to get started might be C:\Program Files (x86)\GHI Electronics\GHI .NET Gadgeteer SDK\Getting Started Guides\FEZHydra Basic Kit Guide.pdf. It was written for an earlier version a kit, but I believe you have all the modules necessary to use the guide. The LED module you have is different, but the code/API for control will work for yours.


#15

As to your comment regards “includes/references” there is a great section called “Assemblies” in the on-line book “Beginners Guide to using .NET Micro Framework”. It starts on page 18.

A link to the book can be found at http://www.ghielectronics.com/support/.net-micro-framework


#16

@ Jeff

Thanks! That did it…finally got it to compile, although it blew up since I don’t have the device with me. But the ‘hard’ part is done. I’m pretty good at reverse engineering things, so that’s why I wanted to tackle something larger like this…now I can see how certain things are done.

I ordered the Gadgeteer book from you guys…(I know the book you mentioned is different…will look at that as well); so that should be waiting for me at home. Nothing else to stop me now. Thanks again!


#17

Thank you for the questions… helps us know where our docs need improvement. I’ve updated the Developer’s Guide for the Kit to include detailed Compilation/Deploy instructions.


#18

Glad that my questions are helping!

Got a couple more. I started from scratch, which means I created a simple “hello” program, and confirmed that it worked as expected(I used the joystick instead of the button).

Then I reloaded the Hydra kit program. Two issues right now:
First is that the camera is not working. The spot where it should be working is all purple. Not sure if it’s the code or not…I’ll have more time tomorrow night to troubleshoot it - perhaps make a new program and just turn it on and pipe it into the display. (I’m still new to programming these things, but I’m sure I can figure that out)

Second thing is that there is no calibration screen and it definitely needs it. Every touch is way off.

Otherwise, this kit is looking like a great playground to learn this…so thanks to everyone involved with putting this together.


#19

Not sure about the purple square? Possible that is the default before you touch activate the panel to take a picture (i don’t have unit at my desk to test that theory right now) and if calibration is off where to tap to get the picture is ???

As to calibration screen, it should appear when you push & release the button connected to socket 5


#20

Thanks Jeff…after asking enough questions, one ended up being a stupid one. I completely missed in the instructions to plug in the button module. So when it said “press the button” I was thinking “What button are they talking about? They need to document this better!”…and to find out that I really just need to READ better!

I plan to use the camera with another project I’m throwing together, so I’ll find out soon if it’s the camera or something else. All set to move on now, thanks!